
Attachment uploads are currently disabled. This is a temporary situation and will resume as normal in the coming days.
UNSOLVED
'Cannot find volume needed' recover error
Hello,
We are trying to recover a file.
The backup is successful.However we can see in the attached print screen from Networker and for 'mlnh101-backup_DB' Save Set a double entry in messages (and 0 size) .
So the first question is if these double messages is something normal.
Then in /nsr/index we can see for this client 2 indexes (different sizes and creation dates)
drwx------ 3 root root 512 Jul 30 00:02 mlnh101
drwx------ 3 root root 512 Jul 30 01:01 mlnh101-backup
If we try to recover a file from this client the error is shown below
root@mlnh101> recover
Current working directory is /
recover> add environment.txt
/
1 file(s) marked for recovery
recover> recover
Recovering 1 file into its original location
Volumes needed:
Unknown
Total estimated disk space needed for recover is 1 KB.
Requesting 1 file(s), this may take a while...
70582:recover: Requesting 0 recover sessions from server.
53365:recover: NSR server `mlncbr01-backup': Cannot find the volume needed
5766:recover: waiting 30 seconds then retrying
53365:recover: NSR server `mlncbr01-backup': Cannot find the volume needed
Next step was to delete mlnh101-The same error occured
Then we deleted mlnh101-backup and could not find index at all.So we concluded that the right index is the mlnh101-backup.
Running nsrck and mminfo outputs are normal
There are no double client ids in the mminfo for the client and the respective save sets.
Any ideas?I 've tried all the recommendations of previous posts for the same error.
Thanks
Anna
Responses (0)
Solutions (0)
