Announcement Banner
UNSOLVED

bigbird5

updated

17 years ago

B

bigbird5

1 Rookie

•

8 Posts

0

4253

October 6th, 2009 06:00

PowerPath on AIX

Is it a problem to have CLArrayS3 and PowerPath on the same AIX system running on OS 6.1?
system IBM,7038-6M2
OS Level 6.1.2.0

filesets
CLArrayS3 5.2.0.7 C F CLARiiON Array Software
EMC.CLARiiON.aix.rte 5.3.0.3 C F EMC CLARiiON AIX Support Software
EMCpower.base 5.1.1.0 C F PowerPath Base Driver and Utilities
EMCpower.consistency_grp 5.1.1.0 C F PowerPath Consistency Group
Extension and Utilities
EMCpower.migration_enabler
5.1.1.0 C F PowerPath Migration Enabler
and Utilities
EMCpower.mpx 5.1.1.0 C F PowerPath Multi_Pathing
Extension and Utilities

NAVIAGENT 6.26.2.0 C F Navisphere Disk Array
Management Tool (AGENT)
NAVICLI 6.26.2.0 C F Navisphere Disk Array
Management Tool (CLI)
  • bigbird5

    1 Rookie

    •

    8 Posts

    1736

    0

    Posted October 6th, 2009 07:00

    Will it cause a problem if the CLArrayS3 software is not removed?
  • Conor

    341 Posts

    1736

    0

    Posted October 6th, 2009 07:00

    Hi BigBird

    PowerPath no longer requires CLArrayS3 fileset, It can be removed.

    Conor
  • Conor

    341 Posts

    1736

    0

    Posted October 6th, 2009 08:00

    No it won't cause any issues to leave it, just ensure that from the output of lsdev -Cc disk that the CLARiiON devices show up as:

    hdisk11 Available 06-08-02 EMC CLARiiON FCP RAID

    and not as

    hdisk11 Available 11-08-01 FC CLArray RAID 5 Disk Group


    In the first example the device is defined with EMC ODM pacakage, in the second the CLArray fileset provides the device definition.
  • bigbird5

    1 Rookie

    •

    8 Posts

    1736

    0

    Posted October 6th, 2009 08:00

    So I should remove the CLArrayS3 software if the lsdev shows up like this?

    hdisk2 Available 1n-08-01 FC CLArray RAID 5 Disk Group
    hdisk3 Available 1n-08-01 FC CLArray RAID 1/0 Disk Group
    hdisk4 Available 14-08-01 FC CLArray RAID 5 Disk Group
    hdisk5 Available 14-08-01 FC CLArray RAID 1/0 Disk Group
    hdiskpower0 Available 14-08-01 PowerPath Device
    hdiskpower1 Available 14-08-01 PowerPath Device
  • Conor

    341 Posts

    1736

    1

    Posted October 7th, 2009 00:00

    Yes - currently the devices are defined by the CLArrayS3 fileset and not the ODM fileset (EMC.CLARiiON.aix.rte 5.3.0.3). To change this we will remove the CLArrayS3 fileset (Offline change) and redefine the devices using ODM 5.3.0.3

    You must remove devices and the old version of CLArray by following these steps:

    1. Unmount any file systems that have LUNs that belong to the CLARiiON array.
    2. Run varyoff for any volume groups that have CLARiiON LUNs in use.
    3. Remove all hdiskpowers and hdisks (rmdev -dl).
    4. Remove all SP devices (sp0,1,2,3) (rmdev -l -d).
    5. Remove all HBA driver and Fiber adapter instances:
    rmdev -Rdl fcsiX ---> X being all instances of the driver i.e. 0,1,2, etc.
    rmdev -Rdl fcsX ---> X being all instances of the cards i.e. 0,1,2, etc.
    6. Remove the old version of CLArray from SMIT or command line.

    We already have the base EMC ODM installed but we will also need one additional fileset to support PowerPath.
    EMC.CLARiiON.fcp.rte
    You can download the complete EMC ODM fileset from
    ftp://ftp.emc.com/pub/elab/aix/ODM_DEFINITIONS/
    Copy the EMC.AIX.5.3.0.3 file into the "/usr/sys/inst.images" directory.

    Invoke smit installp.

    Select option:
    Install and Update from LATEST Available Software

    Use List function to select the "/usr/sys/inst.images" as Installation directory.

    Use List function to select one or more of the following:

    EMC CLARiiON FCP Support Software; IBM Fibre Channel driver support. (Supports PowerPath)
    EMC CLARiiON AIX Support Software; Standard utility support
    EMC CLARiiON FCP MPIO Support Software; IBM default PCM MPIO support.
    EMC CLARiiON AIX Support Software; Standard utility support

    and only these definitions- are required.

    EMC CLARiiON FCP Support Software; IBM Fibre Channel driver support.(Supports PowerPath)


    7. Run cfgmgr, emc_cfgmgr, powermt config, powermt save
    8. varyon all volume groups and mount the file systems

    Let us know how this goes...
  • bigbird5

    1 Rookie

    •

    8 Posts

    1736

    0

    Posted October 12th, 2009 09:00

    I was finally able to get the CLArrayS3 software removed but now I am not able to get the powerpath devices to come back in.
    hdisk2 Available 14-08-02 EMC CLARiiON FCP RAID 5 Disk
    hdisk3 Available 14-08-02 EMC CLARiiON FCP RAID 1/0 Disk
    hdisk4 Available 1n-08-02 EMC CLARiiON FCP RAID 5 Disk
    hdisk5 Available 1n-08-02 EMC CLARiiON FCP RAID 1/0 Disk
    hdiskpower0 Available 14-08-02 PowerPath Device
    hdiskpower1 Available 14-08-02 PowerPath Device

    hdisk2 none None
    hdisk3 none None
    hdisk4 none None
    hdisk5 none None
    hdiskpower0 none None
    hdiskpower1 none None

    154 /tmp/emc > importvg -y data1vg hdiskpower1
    0516-024 lqueryvg: Unable to open physical volume.
    Either PV was not configured or could not be opened. Run
    diagnostics.
    0516-024 lqueryvg: Unable to open physical volume.
    Either PV was not configured or could not be opened. Run
    diagnostics.
    0516-1140 importvg: Unable to read the volume group descriptor area
    on specified physical volume.


    What am I doing wrong?
  • bigbird5

    1 Rookie

    •

    8 Posts

    1736

    0

    Posted October 12th, 2009 09:00

    I can't import the volume group on powerpath device.

    I was finally able to get the CLArrayS3 software removed but now I am not able to get the powerpath devices to come back in.
    hdisk2 Available 14-08-02 EMC CLARiiON FCP RAID 5 Disk
    hdisk3 Available 14-08-02 EMC CLARiiON FCP RAID 1/0 Disk
    hdisk4 Available 1n-08-02 EMC CLARiiON FCP RAID 5 Disk
    hdisk5 Available 1n-08-02 EMC CLARiiON FCP RAID 1/0 Disk
    hdiskpower0 Available 14-08-02 PowerPath Device
    hdiskpower1 Available 14-08-02 PowerPath Device

    hdisk2 none None
    hdisk3 none None
    hdisk4 none None
    hdisk5 none None
    hdiskpower0 none None
    hdiskpower1 none None

    154 /tmp/emc > importvg -y data1vg hdiskpower1
    0516-024 lqueryvg: Unable to open physical volume.
    Either PV was not configured or could not be opened. Run
    diagnostics.
    0516-024 lqueryvg: Unable to open physical volume.
    Either PV was not configured or could not be opened. Run
    diagnostics.
    0516-1140 importvg: Unable to read the volume group descriptor area
    on specified physical volume.


    What am I doing wrong?
  • bigbird5

    1 Rookie

    •

    8 Posts

    1736

    0

    Posted October 12th, 2009 12:00

    figured it out. thanks
  • Conor

    341 Posts

    1736

    0

    Posted October 12th, 2009 12:00

    We need to get the PVID's associated with hdiskpower devices before you can import the VG successfully. Have you tried an ODM cleanup? See EMC Knowledgebase solution emc93300.