I have installed the Dell vCenter Plug-in, and created a connection profile for my ESX hosts. Each one has a working iDRAC and OMSA 6.4 installed. When I test the connection profile, each connection fails, the OMSA connection test says that OMSA is not installed. I can successfully connect using the supplied credentials to each server, and I am surprised by the lack of configuration options for this tool. There is no way to enter an IP address for the iDRAC card for example. How can I fix this problem? Pretty much dead in the water without it. Also, how do you set the SNMP community name?
The reason you see that error message about “OMSA is not installed” could be due to that when you installed the OMSA, you didn't install it with -c option which installs the "Remote Enablement" component of OMSA. And our appliance talks to OMSA thought its remote enablement layer. Without successfully connect to OMSA, the iDrac connection will fail too as we correlate the correct iDrac IP with the server by getting the iDrac IP from OMSA first. Please reinstall the OMSA with –c option and that should solve your issue. Once you pass the connection test from the connection profile, please make sure to run inventory from the Job Queue by clicking the “Run Now”.
"The reason you see that error message about “OMSA is not installed” could be due to that when you installed the OMSA, you didn't install it with -c option which installs the "Remote Enablement" component of OMSA. And our appliance talks to OMSA thought its remote enablement layer. Without successfully connect to OMSA, the iDrac connection will fail too as we correlate the correct iDrac IP with the server by getting the iDrac IP from OMSA first. Please reinstall the OMSA with –c option and that should solve your issue. Once you pass the connection test from the connection profile, please make sure to run inventory from the Job Queue by clicking the “Run Now”. "
Hello Angela,
That indeed was the fix, and the -c is listed in the user guide for the command line, however there is no explanation in the user guide why it needs to be there, so I did not re-run the OMSA 6.4 installer. Perhaps the OMSA team could add the -c switch to the -x (for express) switch for OMSA, so that it is automatically included? Also according to the OMSA 6.4 install manual, if you run the -x switch it runs the express setup with all options included and ignores any other switches, apparently this is not true.
How would this work on ESXi?
I'm installing OMSA with the offline bundle (OM-SrvAdmin-Dell-Web-6.4.0-1266.VIB-ESX41i_A00.7.zip) with command 'esxupdate --bundle /tmp/OM-SrvAdmin-Dell-Web-6.4.0-1266.VIB-ESX41i_A00.7.zip update'. Documentation tells me that 'remote enablement' is installed, but still get errors in the DMP for vCenter about OMSA not being installed on the ESXi host.
I found the ESXi install manual and the commands look different than what you have posted here. Take a look:
http://support.dell.com/support/edocs/software/smsom/6.4/en/omsa_ig/html/instesxi.htm#wp1097009
From what I have seen, remote enablement does not depend on SNMP, it is a seperate feature.
"I found the ESXi install manual and the commands look different than what you have posted here. Take a look:
http://support.dell.com/support/edocs/software/smsom/6.4/en/omsa_ig/html/instesxi.htm#wp1097009
From what I have seen, remote enablement does not depend on SNMP, it is a seperate feature."
I used 'ftp://ftp.us.dell.com/sysman/OM-SrvAdmin-Dell-Web-6.4.0-1266.VIB-ESX41i_A00.7.zip' to install OMSA, enable UserVars.CIMoemProviderEnabled and configured SNMP. The only difference between my actions and the steps in the document you referred to is the addition of @162 in configuring SNMP.
In the console of the management plugin, under connection profiles, I can see the Service Tag of my hosts, after I configured SNMP. I still get the error that OMSA isn't installed on the hosts.
When I use OMSA's web interface on a windows machine ('manage remote node'), I can't log in on the remote ESXi-host, error is 'Internal Error'.
When checking the logfile of the management plugin, I notice entries like:
Inventory failed for host esx04.domain.local. Reason: Server returned HTTP response code: 400 for URL: https://esx04.domain.local:443/wsman
To install OMSA VIB on an ESXi host, you could use VMware CLI tool to remotely install it to your ESXi host using the following:
Vihostupdate.pl -server -i -b OM-SrvAdmin-Dell-Web-6.4.0-1266.VIB-ESX41i_A00.7.zip
Once you installed OMSA, you also need to go to Dell Management Center to create a connection profile (CP) to include this host. And enter the OMSA credentials which is the same credentials as your ESXi host when creating the CP. Then you can test the connection to make sure the OMSA connection passes. After you create the CP with this host, you will need to run the inventory from the Job Queue from Dell Management Center to make sure inventory job success on this host.
You can follow the step on UG p34 "Set up an OMSA trap destination" to configure the SNMP so the vCenter will receives the Dell HW alerts. But this is not required if you only want to get Dell Tab to work. Link to the UG: http://support.dell.com/support/edocs/software/eslvmwre/plugin/
angela_qian
3 Posts
1129
0
Posted March 1st, 2011 13:00