
Attachment uploads are currently disabled. This is a temporary situation and will resume as normal in the coming days.
Solved!
Go to SolutionAU
Anonymous User
242 Posts
1
11954
July 23rd, 2013 12:00
Unbind a dev
Hi, we untagged some dev from recoverpoint. I want unbind them to pool so that they can use. Below is the process i used but i am getting error.
Delete the masking view
Removing the devices from storage group
When i am trying to unbind the dev from pool i am getting below error. And the device is a meta head.
H:\>symconfigure -sid 65 -cmd "unbind tdev 0857 from pool PROD_S7k;" preview
Execute a symconfigure operation for symmetrix '000192604064' (y/ ) ? y
A Configuration Change operation is in progress. Please wait...
Establishing a configuration change session...............Established.
Error occurred while Defining change number 1:
Device must be unmapped or 'not ready' in order to perform the requested ope
ration
Device 0857 generated the failure
Terminating the configuration change session..............Done.
The configuration change session has failed.
Responses (33)
Solutions (0)
codyhosterman
286 Posts
2455
1
Posted July 23rd, 2013 12:00
If you didnt use -unmap in the command when you either deleted the view or removed the device from the SG you will need to use symconfigure to unmap the device.
symconfigure -cmd "unmap dev from dir ALL:ALL;" -v commit -sid XX -nop
Reply codyhosterman
286 Posts
998
0
Posted July 23rd, 2013 12:00
Yep! Need to add "-type storage" to the remove dev command but other than that looks great
Reply Anonymous User
242 Posts
3538
0
Posted July 23rd, 2013 12:00
For unbinding a meta from a pool.
Reply Anonymous User
242 Posts
998
0
Posted July 23rd, 2013 12:00
H:\>symconfigure -sid 64 -cmd "unbind tdev 0857 from dir all:all;" preview
Error in line 1 at symbol 'dir': syntax error
Syntax for unbind command is:
UNBIND TDEV < [: ] |
in DG | in SG > FROM POOL ;
Parser found fatal error in command file entry number 1
The configuration change session has failed.
Reply Anonymous User
242 Posts
997
0
Posted July 23rd, 2013 12:00
Sorry, I used wrong command. For unmapping the dev does dev need to be in not ready state
Reply codyhosterman
286 Posts
3538
0
Posted July 23rd, 2013 12:00
Yeah -unmap only works when:
- Deleting a view
- Removing a device from an SG when it is part of a view.
You will have to use symconfigure
Reply codyhosterman
286 Posts
3538
0
Posted July 23rd, 2013 12:00
When you unbind a meta you only need to specify the head. The members will be unbound automatically
Reply Anonymous User
242 Posts
2081
1
Posted July 23rd, 2013 12:00
k k got you.
From next time if i want to delete a dev i need used below steps right
1. symaccess -sid 1234 -name SGNAME remove dev 01a1 -unmap
2. delte masking view
3. unbind from thin pool
Reply

codyhosterman
286 Posts
3538
0
Posted July 23rd, 2013 12:00
Did you add the -unmap tag to the symmaccess command when you removed the device from the stoage group? Because by default the remove command only removes the masking records but does not remove the mappings to the FA(s).