Announcement Banner
UNSOLVED

MattEMC

updated

12 years ago

M

MattEMC

15 Posts

0

3079

June 26th, 2014 06:00

VMWARE on VNX NFS - Timeout and failover ?

Hi all,

One of my customer use VNX2 File for these VMWARE servers. During Datamover Failover, they encountered some problem with VM causing by the timeout. 

Our EMC Best Practices documents are based on VMWARE values for NFS (see bellow). But, after calculate these values, you understand that the total NFS timeout is 125 seconds. After 125 seconds, the NFS datastore is down and the VM is freeze or stopped.

We know that VNX datamover failover delay can be between 2  or 3 min (150-180 seconds), in this situation, the NFS Datastore will be down before the failover is completed and VM will be down even if the VM Disk timeout is configured with 180 seconds.

What is our solution to ensure the datastore will be still up after the complete failover.

Thanks for your help.

VMWARE NFS values

NFS.HeartbeatTimeout = 12

NFS.HeartbeatMaxFailures = 5

NFS HeartbeatDelta = 5

NFS.HeartbeatFrequency = 10

Minimum time to mark a volume down(minTime) = (HeartbeatFrequency * (HeartbeatMaxFailures - 1)) + HeartbeatTimeout
Maximum time to mark a volume down(maxTime) = HeartbeatDelta + HeartbeatFrequency + minTime

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1007909