Announcement Banner
UNSOLVED

jzhang2006

updated

6 years ago

J

jzhang2006

1 Message

0

825

January 18th, 2021 09:00

Using dellemc_unity_filesystem module to create filesystem getting error

I am using ‘Ansible Modules for Dell EMC Unity’ with Unisphere 5.0.2, Python 3.6 and Storops 1.2.8 and Ansible 2.9 on Centos 7. The use case I am working on is filesystem creation using Ansible ‘dellemc_unity_filesystem’ module. I am able to create UNIX fs without problem. But when I try to create WINDOWS or NATIVE type of filesystems, I am getting an error:

Failed to modify FileSystem instance id: fs_42 with error Modifying access policy for a non-multiprotocol file system is not allowed. (Error Code:0x6701426

The filesystem is created with Unix type even it fails with the above error when I specify 'WINDOWS' or 'NATIVE' type. Anything might be wrong here?

  • FoolInTheRain

    2 Intern

    •

    123 Posts

    658

    0

    Posted January 19th, 2021 07:00

    Hi jzhang2006,

    It appears you are using the ‘Ansible Modules for Dell EMC Unity’ version 1.1, since you mentioned "Windows" and "Native" while using the ‘dellemc_unity_filesystem’ module.

    Your setup seems fine (CentOS7 instead of Red Hat linux was all I saw).

    Can you share the parameters used in the calls to create and/or modify the filesystem that you used?

    Can you reproduce the issue using the debug option (-vvv) just in case that contains more info?

  • FoolInTheRain

    2 Intern

    •

    123 Posts

    654

    0

    Posted January 19th, 2021 08:00

    I just found out the issue was identified and has already been resolved.

    It appears the original issue was a result of:

                  The user “…did not set supported_protocols so the default goes to NFS so only UNIX access_type worked…”

    This was corrected and it fixed the problem.