UNSOLVED

StuartMc1

updated

13 years ago

S

StuartMc1

1 Message

1

5350

April 1st, 2014 08:00

Restore issues from Avamar

I am getting avtar error 9909 whenever I go to restore a set of files:

   

2014-04-01 11:03:26 avtar Error <9909>: Unable to restore D:\EBB Login Master.xlsx, cannot find data (Log #1)
2014-04-01 11:03:27 avtar Error <9909>: Unable to restore D:\Master Scheduling Sheets\TCO YYYY-MM.xlsm, cannot find data (Log #1)
2014-04-01 11:03:27 avtar Error <9909>: Unable to restore D:\Master Scheduling Sheets\Trunkline YYYY-MM.xlsm, cannot find data (Log #1)
2014-04-01 11:03:27 avtar Error <9909>: Unable to restore D:\2014-02\DTI 2014-02.xlsm, cannot find data (Log #1)
2014-04-01 11:03:27 avtar Error <9909>: Unable to restore D:\Master Scheduling Sheets\ANR YYYY-MM.xlsm, cannot find data (Log #1)
2014-04-01 11:03:27 avtar Error <9909>: Unable to restore D:\Master Scheduling Sheets\Appalachia Transport YYYY-MM.xlsm, cannot find data (Log #1)
2014-04-01 11:03:27 avtar Error <9909>: Unable to restore D:\Master Scheduling Sheets\Appalachia YYYY-MM.xlsm, cannot find data (Log #1)
2014-04-01 11:03:27 avtar Error <9909>: Unable to restore D:\Master Scheduling Sheets\CGT YYYY-MM.xlsm, cannot find data (Log #1)
2014-04-01 11:03:27 avtar Error <9909>: Unable to restore D:\Master Scheduling Sheets\DTI YYYY-MM.xlsm, cannot find data (Log #1)
2014-04-01 11:03:27 avtar Error <9909>: Unable to restore D:\Master Scheduling Sheets\Equitrans YYYY-MM.xlsm, cannot find data (Log #1)
2014-04-01 11:03:27 avtar Error <9909>: Unable to restore D:\Master Scheduling Sheets\PEPL YYYY-MM.xlsm, cannot find data (Log #1)

  When I look at the files that have been restore on the server I cannot open them.

Any ideas?

Thanks in advance!

~Stuart

  • 2532

    0

    Posted November 4th, 2014 16:00

    on the client where the document will be restored, please create a new text file in C:\Program Files\avs\var named avtar.cmd. Open this of edit and add the flag: --deflateofficexml=false


    Here is a detailed explanation: When the v4.x or v5.x Avamar Windows file system client backs up certain Office Open XML files (specifically, docx, docm, dotx, dotm, xlsx, xlsm, xltx, xltm, and xlsb), by default, the avtar process unzips ("inflates") the Office Open XML file and backs up the XML-based files to the Avamar server. During the restore process back to the Windows client, the avtar process restores the various components and then zips ("deflates") the XML-based files together to re-create the file in the Office Open XML format.

  • Leo Li

    4 Apprentice

    •

    9030 Posts

    2532

    1

    Posted November 5th, 2014 18:00

  • Leo Li

    4 Apprentice

    •

    9030 Posts

    2532

    0

    Posted November 19th, 2014 20:00

    Hi,

    How is the issue now?

    Please help to mark above replies as "correct/helpful answer" if you think they are helpful to you. Thank you.

  • 2532

    0

    Posted November 19th, 2014 20:00

    it works great for me with the flag deflat = false

  • der1

    7 Posts

    2532

    0

    Posted January 16th, 2015 01:00

    Hello, I got the same issue on a Windows 2008 SP2 client running Lotus Domino and backing up .nsf files.

    The flag --deflateofficexml=false doesn't help in my case.

    Any suggestion?

  • der1

    7 Posts

    2538

    0

    Posted January 16th, 2015 02:00

    Arturo, files are backed up but looks like they are unusable because importing .nsf files into Lotus Domino I get the error "File is not a database"

    Furthermore the backup log reports for all files:

    avtar Error <5139>: File access share error "H:\Lotus\Domino\Data\mail\xxx\xxx.nsf" (code 32: The process cannot access the file because it is being used by another process). (Log #1)

  • arturo3

    40 Posts

    553

    0

    Posted January 16th, 2015 02:00

    This error usually means that VSS Snapshot failed so backup was done on production data instead of VSS snapshot, so Avamar wasn't able to access file because it was opened or locked by another process and file consistency cannot be ensured.

    Is xxx.nsf from previous comment the file you are trying to restore?

    I would analyze why VSS snapshot failed, backup should have been completed with exceptions.

    Regards

  • der1

    7 Posts

    2538

    0

    Posted January 16th, 2015 02:00

    Hi Arturo,

    I'm using Windows File System Plugin and here after the error I got on restore:

    avtar Error <9909>:  Unable to restore C:\bck\file.nsf, cannot find data (Log #1)

  • arturo3

    40 Posts

    2532

    0

    Posted January 16th, 2015 02:00

    Hi,

    deflateofficexml flag shouldn't apply to nsf files, it should be applied on office xml files. Some questions here:

    a) Are you backing up nsf file using filesystem or Lotus plugin?

    b) Could you let me know with errors you got on restore?

    Regards

    Arturo

  • arturo3

    40 Posts

    2538

    0

    Posted January 16th, 2015 02:00

    Could you dump backup content to check if file is there?

    avtar --list --labelnum=X --verbose=1 --acnt=/ / 2>&1 |tee -a backupcontents.log

    grep file.nsf backupcontents.log