Announcement Banner
UNSOLVED

Rami1

updated

20 years ago

R

Rami1

2 Intern

•

131 Posts

0

2898

February 19th, 2007 06:00

Navisohere: cannot create raid group: SPA: Array Microcode error

Hi,

iam trying to create a raid group on ATA disks in CX300. there is already a raid group created and a hotspare. but iam trying to create a new raid group of 6 ATAs, it is giving an error:

can not create raid group: SPA: Array Microcode Error: 0x560, SPB: Array Microcode Error: 0x560

please i need help on this
  • kelleg

    6 Operator

    •

    4537 Posts

    982

    0

    Posted February 19th, 2007 10:00

    A little more information would be helpful:

    1. Which version of flare are you running (base code on the array)?

    2. Are the six ATA disks free (not already in a Raid Group)?

    3. Where are you getting the error? During the "Create Raid Group" windows or after?

    4. Has there been a flare code upgrade recently? Was the software committed?
    4a. check the Software Properties page and see if there are any packages that need to be "committed"

    glenk
  • Rami1

    2 Intern

    •

    131 Posts

    982

    0

    Posted February 19th, 2007 21:00

    1. Which version of flare are you running (base code on the array)?
    2.19.300.5.019

    2. Are the six ATA disks free (not already in a Raid Group)?
    yes they are free. by the way, i have added them recently to the enclosure.

    3. Where are you getting the error? During the "Create Raid Group" windows or after?
    iam getting the error after i select the disks for my raid group when clicking apply as the last step.

    4. Has there been a flare code upgrade recently? Was the software committed?
    4a. check the Software Properties page and see if there are any packages that need to be "committed"
    no upgrade has been done, and yes the running FLARE code is committed.
  • Rami1

    2 Intern

    •

    131 Posts

    986

    0

    Posted February 19th, 2007 23:00

    hi,

    i forgot to mention that i have created a 1 T LUN before on the ATAs then i unbinded it and destroyed the RAID group. then i tried to recreate another raid group,and the error appeared.
    please provide suggestions as soon as possible.
  • Kiran3

    410 Posts

    986

    0

    Posted February 20th, 2007 00:00

    its not clear to me...
    if you have moved the disks while RAID groups were bound on them, that causes issues..the disks should be unbound before you can move them between arrays.

    if you moved disks by unbinding them, were you able to delete the RG succesfully or was there any error?

    if you see latest sp logs, are there any "CRU Signature errors"?
  • Rami1

    2 Intern

    •

    131 Posts

    986

    0

    Posted February 20th, 2007 00:00

    i have moved one drive by another, but i did managed before to create a raid group on them a create a 1T LUN and it worked fine. but after removing them, and tried to create another raid group, its giving me this error
  • Kiran3

    410 Posts

    986

    0

    Posted February 20th, 2007 00:00

    2. Are the six ATA disks free (not already in a Raid Group)?
    yes they are free. by the way, i have added them recently to the enclosure.



    did you move the drives between arrays?
  • Rami1

    2 Intern

    •

    131 Posts

    986

    0

    Posted February 20th, 2007 02:00

    well, here is a description of what is going on:

    i had an ATA enclosure having 5 disks ( 0-4 ). then we upgraded the storage and added 6 new ATA drives to the enclosure.

    both new and old disks have exactly the same properties regarding the capacity and the speed.

    whenever iam including disk(4) with the new disks for creating a RAID Group its giving the mentioned error. so, what i did is that created successfully a raid group of disks 5 to 10. then i tried to make disk 4 as a hotspare but still the sma eroor occurs.
    hope this information might help
  • Kiran3

    410 Posts

    986

    1

    Posted February 20th, 2007 03:00

    okay...so you have a set of old 5 and new 6 disks on this enclosure.

    whenever iam including disk(4) with the new disks for creating a RAID Group its giving the mentioned error


    what if you create a raid group in old set, are you able to do this? Earlier you mentioned that you are not able to create rg on 6 disks...were those the new set of disks? i felt something contradicting.

    if you are not able to combine disks from between these sets, maybe the firmware present on the disks itself has some issue.

    2.19.300.5.019

    Can you upgrade the code? path 19 is quiet old code i believe. latest patch should be 40. upgrade to patch 30 atleast since it had some upgrades for ATA code.
  • kelleg

    6 Operator

    •

    4537 Posts

    986

    0

    Posted February 20th, 2007 09:00

    Disks 0-4 are part of what is referred to as the OS disks or Vault drives. Disk 4 (the fifth disk counting from the left) is where we store the recovery images for the OS.

    When you use any of these disks (0-4) with other disks in the enclosure, you get slightly less available space (the space that is reserved for the OS/Vault functions) on all the other disks. You can not use disk 4 as a hotspare.

    Disk 4 may be down on one-side of the dual bus - try issuing the following command from a DOS prompt from within the c:\program files\emc\navisphere cli directory:

    navicli -h IP_Address_SPA get disk 0_0_4 -state
    navicli -h IP_Address_SPB get disk 0_0_4 -state

    The "state" should be "ENA" for both sides - if one side is different, say PUP (powering up), then the disk is stuck and may need to be reseated (this does not always work).

    If the above is true, the lights on the disk will be green and amber - which I assume you've already looked at.

    glenk
  • EKellerman

    76 Posts

    238

    0

    Posted February 20th, 2007 12:00

    Rami said that these were ATA drives....Does EMC support putting FLARE on ATA Drives? He never mentioned what Bus or Enclosure this was either.