I'm having a really aggravating problem with our MD3000 and our two Dell R805 servers. Both servers run XenServer 5.5 and share the MD3000 on the Dell SAS backplane. We only have single-RAID controllers in the MD3000. Server A is connected from HBA port 0 to the "IN" on the MD3000's RAID controller 0. Server B is the same way -- HBA0 -> RAID controller 1. I wish we had full redundancy, but the dual RAID controller option for the MD3000 was a bit too pricey for our investors, and we had to stick with the single.
The MD3000 is set up in XenServer as the default storage device, and neither server have any problems at all connecting to the array for read/write operations. In fact, we have several virtual machines spanning the two servers and they all run quite well.
The problem is that our logs from both Server A and B are simply full of failover notifications. This is also reflected when I open the Dell Modular Disk Storage Manager on my PC. The array seems to be "flapping" almost constantly between "optimal" and "non-optimal." The specific error message displayed every time is "Virtual Disk Not On Preferred Path." It goes away for a second, then comes back. Over and over again.
I conducted some attempts to clear up this problem this morning to no avail. I clicked on Modify->Change Virtual Disk Ownership/Path, then selected a different HBA. The problem continued. Tried going back to the original "owner," same thing. Replaced the SAS backplane cables, no luck. Even used different ports on the server's HBA's. I did notice that when I migrated the virtual machines over from one server to another, effectively stopping disk activity on one server, I was free of the errors. It's almost as if a failover is triggered every time both systems attempt to perform any disk activity on the MD3000.
Resolved. The initial Dell technician mistakenly loaded NVSRAM for the dual-port version of the MD3000. Spoke with a rep today and he downloaded the latest version for single-port clustering. Even though we're not running a cluster, the image worked and we are error-free. Whew.
Jeremy_ITBox
7 Posts
303
0
Posted October 23rd, 2009 10:00