Announcement Banner
UNSOLVED

AnandB1

updated

17 years ago

A

AnandB1

15 Posts

0

1632

June 11th, 2009 02:00

Disaster recovery for the DB2 server

Hi ,

I am trying to recover the Db2 database on the Dr site.

The primary networker server name is A. the secondary networker server name is B which is also a DB2 server on Dr site.

the DB2 server name on the primary site is B. Using scanner -i , I have populated the CFi and media index for B.

Now when I am trying to restore the Db2 database, it fails. can any one please let me know the exact DR procedure for Db2 database.


regards
Anand
  • HabibG2

    455 Posts

    831

    0

    Posted June 11th, 2009 02:00

    We need more information.

    Detailed your platform.
    How you are performing your recover?
    What error message are you getting?
    At what point is the restore failing?
  • DavidHampson

    2 Intern

    •

    1080 Posts

    831

    0

    Posted June 11th, 2009 03:00

    Could you post the error message as the information here is too vague to give you anything constructive.
  • jasonlee1

    10 Posts

    831

    0

    Posted June 11th, 2009 12:00

    Is the equipment at the DR site in a closed-off network that duplicates the exact hostname and ip conventions of your production site? My first guess would be to verify that hostname resolution is ok both ways between networker server and db2 server at the DR site.
  • jasonlee1

    10 Posts

    831

    0

    Posted June 11th, 2009 13:00

    Is the equipment at the DR site in a closed-off network that duplicates the exact hostname and ip conventions of your production site? My first guess would be to verify that hostname resolution is ok both ways between networker server and db2 server at the DR site.
  • AnandB1

    15 Posts

    831

    0

    Posted June 24th, 2009 19:00

    the error message is as follows:

    512014#0 Tue May 19 11:25:28 2009 nsrdb2_check_init_input: NMDB2_ERROR: Error opening db specific debug log file /nsr/restdebug

    512014#0 Tue May 19 11:25:28 2009 sqluvint: NMDB2_ERROR
    503822#0 Tue May 19 11:26:44 2009 nsrdb2_set_restore_object: NMDB2_WARNING: BSAQueryObject found no matches
    503822#0 Tue May 19 11:26:44 2009 sqluvint: NMDB2_ERROR: nsrdb2_set_restore_object()
    503822#0 Tue May 19 11:26:44 2009 sqluvint: NMDB2_ERROR: no matching backups found
    503822#0 Tue May 19 11:26:44 2009 sqluvint: NMDB2_ERROR
    442442#0 Tue May 19 11:31:10 2009 nsrdb2_open_debug_file: NMDB2_ERROR: Cannot open db file /nsr/restdebug

    442442#0 Tue May 19 11:31:10 2009 nsrdb2_check_init_input: NMDB2_ERROR: Error opening db specific debug log file /nsr/restdebug

    442442#0 Tue May 19 11:31:10 2009 sqluvint: NMDB2_ERROR
  • AnandB1

    15 Posts

    831

    0

    Posted June 24th, 2009 19:00

    The DB2 server is also serving as the Networker server, therefore there is no issue of the hostname resoultiuon.
  • ble1

    6 Operator

    •

    14354 Posts

    •

    56186 Points

    831

    0

    Posted June 25th, 2009 00:00

    The error seems to suggest that query against the index resulted in no backups found for this client. Without looking closely to configuration it is going to be hard to figure out what went wrong.
  • AnandB1

    15 Posts

    831

    0

    Posted June 25th, 2009 01:00

    Can you please let me know what will be the exact steps for the Db2 disaster recovery.
  • ble1

    6 Operator

    •

    14354 Posts

    •

    56186 Points

    831

    0

    Posted June 25th, 2009 01:00

    I didn't do it, but I would guess following:
    - you install DB2 as before with same name on the client with the same name (unless you do directed recovery)
    - you run restore