Announcement Banner

ribosom1

updated

7 months ago

R

ribosom1

1 Rookie

•

23 Posts

2

83510

December 15th, 2013 03:00

Error 1920 / Service failed to start during client install

I have two clients running Windows 2008 Standard which refuse to have the Networker client installed on them. The problem is that at the very end of the install nsrexecd fails to start with the error:

Error 1920. Service nsrexecd failed to start. Verify you have sufficient privileges to start system services.

After this I have to cancel and the install is rolled back.

The service is using the local system account, and I am using domain admin account for the installation. The available articles suggest to attempt install to a different disk/location, but it did not help. Same thing happens for 8.0.1 and 7.6.5 install. Server has already been rebooted.

Any tips where to look next?

Thanks.

  • kciolek_emc

    16 Posts

    61266

    1

    Posted February 5th, 2014 08:00

    I had the same issue while installing Networker 8.1 client on Hyper-V server. I tried changing the startup account but didn’t work. We actually had to change the default timeout on the Windows services from 30 seconds to 1 minute and fixed the issue. We worked with support and engineering and determined the cause to be with the Hyper-V servers being setup in a 4 node cluster and needing extra time to start. This was the case on all Hyper-V servers in cluster.

    Ken Ciolek

    EMCISA, EMCIEs, EMCIEe, EMCTAs, EMCCIS

    Solutions Architect

    Data Protection & Availability

    PS Americas East (NY/NJ) Delivery

    EMC2

    Center 78

    184 Liberty Corner Road, 4th Floor

    Warren, NJ 07059

    mobile: 201-983-1537

    email: Kenneth.CiolekJr@emc.com

    1 Attachment

  • crazyrov

    6 Operator

    •

    1319 Posts

    51386

    0

    Posted December 15th, 2013 19:00

    Open a command prompt as an adminiatrator . I.e right click on the command prompt icon and select "Run as Administrator". Launch the networker.msi from within the command prompt.

    --- Original Message ---

  • kciolek_emc

    16 Posts

    51388

    2

    Posted December 15th, 2013 19:00

    Hi guys,

    I’m having the same issue with a customer, the environment is a Windows 2012 Hyper-V server and Networker 8.1 client. I had tried all the suggestions and currently working with support and engineering, they think the issue has to do with windows service start-up time, the default 30 seconds isn’t long enough to start the service and eventually times out. Support has tested this and was able to recreate the problem in their lab and work around resolved the issue. The work around is to extend the default start-up time for the services from 30 seconds to 10 minutes. Keep in mind this is a global change and affect default startup time for all windows services. It hasn’t been listed as a bug in Networker as of yet. We have yet to try the fix with customer, hopefully sometime this week.

    Thanks,

    Ken Ciolek

    EMCISA, EMCIEs, EMCTAs, EMCCIS

    Solutions Architect

    Data Protection & Availability Division (DPAD)

    PS Americas East (NY/NJ) Delivery

    EMC2

    Center 78

    184 Liberty Corner Road, 4th Floor

    Warren, NJ 07059

    mobile: 201-983-1537

    email: Kenneth.CiolekJr@emc.com

    1 Attachment

  • TimQuan

    6 Operator

    •

    1242 Posts

    51386

    2

    Posted December 15th, 2013 19:00

    I suggest:

    1. Uninstall any NetWorker components from appwiz.cpl (Programs and Features in Control Panel).
    2. Reboot the computer into Safe Mode (When restarting, keep pressing F8 and select Safe Mode).
    3. Open cmd, copy and paste the following command and press Enter.

    REG ADD HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Minimal\MSIServer/VE/TREG_SZ/F/D %Service%

    4. Type the following command and press Enter:

    net start msiserver

    5. Install NetWorker again.

    If the issue persists, please verify whether the installation package is correct. In addition, please check whether you can install Office components or Windows Live Messenger (check if Windows Installer is good).

  • TimQuan

    6 Operator

    •

    1242 Posts

    51386

    0

    Posted December 15th, 2013 19:00

    You can also try:

    Right-click the installation package and click Run as administrator. Then install the package.

  • crazyrov

    6 Operator

    •

    1319 Posts

    51395

    0

    Posted December 15th, 2013 19:00

    The last time I tried the right click on the msi file did not list the run as administrator option. Anyways its worth a try.

    --- Original Message ---

  • TimQuan

    6 Operator

    •

    1242 Posts

    51395

    0

    Posted December 15th, 2013 19:00


    OK. This indicates UAC has already been turned off on your computer and you can ignore this suggestion.

  • ribosom1

    1 Rookie

    •

    23 Posts

    51388

    0

    Posted December 15th, 2013 21:00

    I forgot to mention that I do use "Run as Administrator" option to start the installation.

    The service gets stuck in the "Starting" state, so maybe Kenneth is on something here. Kenneth, did youo get the same error message after it failed to start within the allotted time? I guess it isn't really a permission problem because it would pop up immediately, not after a while.

    Also, unlike most of our clients, these two are 32 bit.

    I will try the rest of the suggestions if we can get a downtime as this is a production server.

  • kciolek_emc

    16 Posts

    51385

    0

    Posted December 16th, 2013 06:00

    Yes….same exact error. We had tried all the previous suggestions, also had Microsoft look into OS issues and nothing. Support finally came up with what I posted earlier and in my case they think it had to do with multiple Hyper-V clusters. The environment was 4 Hyper-V clusters we’re trying to install Networker client on, 2 of them were successful and the other 2 had this error.

    Ken Ciolek

    EMCISA, EMCIEs, EMCTAs, EMCCIS

    Solutions Architect

    Data Protection & Availability Division (DPAD)

    PS Americas East (NY/NJ) Delivery

    EMC2

    Center 78

    184 Liberty Corner Road, 4th Floor

    Warren, NJ 07059

    mobile: 201-983-1537

    email: Kenneth.CiolekJr@emc.com

    1 Attachment

  • ribosom1

    1 Rookie

    •

    23 Posts

    22216

    0

    Posted December 16th, 2013 21:00

    Thanks, sounds promising, we will give it a go.