Announcement Banner
UNSOLVED

compata

updated

12 years ago

C

compata

14 Posts

0

103494

October 3rd, 2014 18:00

Default boot device

I've now experienced this behavior on two machines and expect it will occur on all future servers I install. So I'd love to find a better solution.

I'm trying to install Fedora using PXE kickstart on an R210 II with two disks. My kickstart detects that there are two disks and establishes an LVM volume spanning both of them. The kickstart completes normally but when the unit reboots, the screen goes dark and nothing happens. After some trial and error, I've found that it is trying to boot from the second disk. Of course, the boot loader is on the first disk so this fails.

My current workaround is to enter BIOS setup, disable the second disk, reboot (which starts properly but fails when the full LVM can't be found), go back to setup and re-enable the second disk, then boot again. From then on, the unit continues to boot from the first disk as it should, even if I repeat the kickstart installation. But this manual process will severely impact any attempt to install on a large number of machines in an automated way.

I've been unable to find anything in setup which seems related to this behavior. Ideally, I'd like to make any required BIOS setting at the same time I enable PXE on one of the interfaces. But if I have to modify the kickstart process, that will also work.

  • Daniel My

    12 Elder

    •

    6205 Posts

    4859

    0

    Posted October 4th, 2014 15:00

    Hello

    Boot into the boot manager via F11. You should be able to change the HDD boot order from there. I'm not sure why the system is booting from HDD 1 instead of HDD 0 by default.

    Thanks

  • compata

    14 Posts

    4859

    0

    Posted October 9th, 2014 16:00

    Nice thought but not a solution. When I use F11 immediately after an installation, the default shows as the first disk (both are the same model so I'm going by the position in the list). But selecting that one results in the same failure. Using F11 and selecting the second disk causes a successful boot.

    However, the machine does not remember that. Subsequent boots also fail unless I use F11 and select the second disk every time. The only permanent solution, so far, is the double boot after setup that I described above.

  • Daniel My

    12 Elder

    •

    6205 Posts

    4859

    0

    Posted October 9th, 2014 16:00

    Nice thought but not a solution. When I use F11 immediately after an installation, the default shows as the first disk (both are the same model so I'm going by the position in the list). But selecting that one results in the same failure. Using F11 and selecting the second disk causes a successful boot.

    It does not appear that the system is having issues or is improperly booting to the second drive. It sounds like the operating system is being installed to the second drive.

    Based on the information you have provided I don't see a problem with the server. I would suggest that you troubleshoot your installation procedure to get the OS installed on disk 0. The drive enumeration within the operating system may be different than how the drives are enumerated on the controller.

    Thanks

  • compata

    14 Posts

    4859

    0

    Posted October 9th, 2014 19:00

    "It does not appear that the system is having issues or is improperly booting to the second drive. It sounds like the operating system is being installed to the second drive."

    That thought occurred to me. However, please recall the workaround procedure I described above. When I tell the BIOS to ignore the second disk, the machine boots. Therefore, the OS must be on the first disk. The boot fails because it can't find everything needed (some is on the second disk), but it starts and gets a long way. Before I disable the second disk (SATA port B in the BIOS), the machine won't boot at all.

  • Daniel My

    12 Elder

    •

    6205 Posts

    4859

    0

    Posted October 10th, 2014 09:00

    When I tell the BIOS to ignore the second disk, the machine boots.

    Maybe my reading comprehension is not functioning correctly today, or you might have written it incorrectly. It is my understanding that the system boots fine from the SECOND disk in the boot list; which means that you are installing the OS to the second disk.

    Using F11 and selecting the second disk causes a successful boot.

  • compata

    14 Posts

    4859

    0

    Posted October 10th, 2014 11:00

    Apparently I need a primer on disk numbering. I would assume that SATA port A would be connected to disk #1, port B to disk #2. I would also assume that the F11 display would show the disks in that order, with the one attached to port A on top. But since my two disks are the same model, its not easy to be sure.

    I agree that the results are contradictory. The machine boots properly when the lower disk in the F11 display is selected. It also boots properly (almost) when SATA port B is disabled.

    It does appear that there is some confusion on disk numbering and it may well be that the OS installation has interpreted the numbering incorrectly. But I know that it is simply going by what the BIOS tells it are the first and second disks.

  • compata

    14 Posts

    4876

    0

    Posted October 20th, 2014 15:00

    A response would be appreciated.

  • Daniel My

    12 Elder

    •

    6205 Posts

    4876

    0

    Posted October 22nd, 2014 06:00

    A response would be appreciated.

    Please specify what your question was.

    In response to your previous post please refer to my earlier post:

    Based on the information you have provided I don't see a problem with the server. I would suggest that you troubleshoot your installation procedure to get the OS installed on disk 0. The drive enumeration within the operating system may be different than how the drives are enumerated on the controller.

    The enumeration is handled by the operating system.

    Thanks

  • compata

    14 Posts

    4876

    0

    Posted October 22nd, 2014 12:00

    The enumeration /may be/ handled by the OS, but that does not explain the contradictory results in the BIOS. My questions, implied above, are: How is it possible that the BIOS causes the boot to work when the lower entry in the F11 display is selected but also causes the boot to work when SATA port B is disabled? What is the relationship of SATA ports to the BIOS representation? Which of these two results does the BIOS give to the OS so that the OS can perform enumeration?

  • Daniel My

    12 Elder

    •

    6205 Posts

    978

    0

    Posted October 22nd, 2014 16:00

    How is it possible that the BIOS causes the boot to work when the lower entry in the F11 display is selected but also causes the boot to work when SATA port B is disabled?

    I don't know.

    The F11 list does not correspond to the physical enumeration. The F11 one time boot menu is listed by device boot order. If you are choosing the second SATA device in the list to boot successfully then the boot loader is not installed properly on the first boot device.

    The functionality of the server at this level is extremely basic. All you have to do to check the boot order of the SATA devices is to review the system BIOS settings. You should be able to review the SATA boot order by going to boot settings>Set Legacy HardDisk Drive Order. The drives should be listed as #00, #01, etc. 00 would correspond with slot A.

    Either the boot order is not set to default or there is an issue with how the OS is being installed. Our PERC controllers will enumerate according to the physical installation in supported Linux distros. I do not believe the SATA chipset controller supports this feature.