Announcement Banner
UNSOLVED

ccollins11

updated

10 years ago

0

2506

December 1st, 2016 12:00

vmcli.exe - Failed to acquire credentials

Hello,

I use vmcli.exe to load our OS and with new R630 servers we received with iDRAC 2.40.40.40, I now get the following error.  Any suggestions?

Security Alert: Certificate is invalid - self signed certificate
Continuing execution. Use -S option for vmcli to stop execution on certificate-related errors.
 Failed to acquire credentials.
Terminating

Thanks!

Casey

  • DELL-Josh Cr

    Community Manager

    •

    9738 Posts

    •

    44386 Points

    1523

    0

    Posted December 1st, 2016 16:00

    Hi,

    The 2.40.40.40 iDRAC firmware changed the default TLS version to 1.1. Changing it back to 1.0 should allow it to work. In the idrac, under iDRAC Settings>Network>Services and try changing the setting from tls 1.1 to 1.0

  • 1523

    0

    Posted December 1st, 2016 18:00

    Hi Josh,


    I had ran into that issue a couple weeks ago with R730s with 2.40.40.40.  It did resolve it on those but the error was different.  On those it was "SSL Connection error" which is different than the credential error I'm getting on the R630s.  I have already set my R630s to 1.0 but it didn't resolve the credential error.  Any other ideas?

    Thanks!

    Casey

  • 1523

    0

    Posted December 2nd, 2016 11:00

    Thanks Josh.  This is in an integration facility and the servers need to ship out to customers ASAP.  I had to give up on a workaround with 2.40 last night and downgraded them to 2.30.  They worked fine once I did that. 

  • DELL-Josh Cr

    Community Manager

    •

    9738 Posts

    •

    44386 Points

    1523

    0

    Posted December 2nd, 2016 11:00

    Can you try using the –s and see if it halts the process or continues? You may also want to try and not self signed certificate. http://en.community.dell.com/techcenter/systems-management/w/wiki/11443.idrac-web-server-certificate-management

  • 1523

    0

    Posted April 7th, 2017 11:00

    I tried again with the newer version of vmcli.exe in DRAC tools 8.5 and it's working again.  I did have to change the TLS back to "1.1 or higher" though for some reason, when called from our C# application.  From the command line it worked fine still at 1.0.