Announcement Banner
UNSOLVED

mbartle

updated

15 years ago

M

mbartle

10 Posts

0

36309

January 15th, 2012 18:00

iSCSi and Switch setup

I posted a question ealier and received no reply so I will reword and try again.

I have purchased the following devices:

1 PowerVault MD3220i redundant iSCSi connectors

2 PowerConnect 6224 Switches

2 PowerEdge R410 Servers with onboard dual Gbe nics

I have used the default config for the SAN which is:

RAID CM 0 port 0 : 192.168.130.101

RAID CM 0 port 0 : 192.168.131.101

RAID CM 0 port 0 : 192.168.132.101

RAID CM 0 port 0 : 192.168.133.101

RAID CM 0 port 0 : 192.168.130.102

RAID CM 0 port 0 : 192.168.131.102

RAID CM 0 port 0 : 192.168.132.102

RAID CM 0 port 0 : 192.168.133.102

In this configuration it looks like i should have 4 iscsi vlans. (one for each subnet) but a lot posts recommend only 2 vlans. What does dell recommend and what would be the setup?

Also, the 2 servers that we have will be setup in a vmware high availability setup, so one server will be the main and the other the backup (i believe thats the way it should be) or should they both be used? How do you connect the 2 nics on each server? Should one be used for iscsi or both with multiple vlans including the iscsi?

Any help would be appreciated.

  • JOHNADCO

    2 Intern

    •

    847 Posts

    473

    0

    Posted January 19th, 2012 13:00

    For best redundancy go a head and make one lan port on board for iSCSI and one on the 4 port for iSCSI.  That way either card and/or lan subsection the motherboard can fail and you will still have access to your storage.

  • mbartle

    10 Posts

    473

    0

    Posted January 31st, 2012 07:00

    Question

    I ordered and recieved the Dell / Intel Gigabit ET NIC,Quad Port, Copper, PCIe-4 cards.

    Went to install them and realized that there are PERC H700 Raid Controller in each of the systems. Obviously there is only one PCIe slot so the Raid controllers will have to be removed. (Should have ordered these servers myself) Can I remove these cards and use the onboard RAID without much performance degradation?

  • mbartle

    10 Posts

    473

    0

    Posted January 31st, 2012 08:00

    SAS 6/iR card? Do you mean onboard?

    Do RAID options really matter? The SAN provides your main backup anyway and if something fails it moves over to the backup srvr anyway. Am I right on this?

    Why did you order a replacement host? Couldn't you have just taken out the RAID controller and installed the 4 port GE card and then used the onboard RAID? Is there something I'm missing?

  • JOHNADCO

    2 Intern

    •

    847 Posts

    473

    0

    Posted January 31st, 2012 08:00

    Bummer....   We ran into the same thing with R415's....

    Luckily only one host was ordered wrong, but it was months before we realized it.   They told me I could not change it after the fact. They told me they would not take the host back as it had been to long.  I had to order a replacement host.

    Really important on these to use the SAS 6/iR card to keep that slot available.  Really limits your RAID options though not to bad with 2TB SATA drives, you can have 2TB mirrored at least.

  • Kong Yang

    180 Posts

    473

    0

    Posted February 20th, 2012 08:00

    Malcolm

    The SAS 6/iR is the onboard controller.

    Onboard RAID matters when you need the redundancy and availability of the local drives for your local data. You will get some level of redundancy and availability with every RAID level except RAID 0 which just spans across disk to give you capacity & spindles but at the cost of losing the whole volume if just one drive in the RAID 0 fails.

  • JOHNADCO

    2 Intern

    •

    847 Posts

    473

    0

    Posted February 25th, 2012 06:00

    "Why did you order a replacement host? Couldn't you have just taken out the RAID controller and installed the 4 port GE card and then used the onboard RAID? Is there something I'm missing?"

    A somewhat outdated IT policy still in place at our company states O/S and Hypervisor loads have to be on a raid 1 mirror at min.

  • mbartle

    10 Posts

    473

    0

    Posted February 25th, 2012 06:00

    I did not order a replacement host, I have done exactly what you have said.

    Unfortunately, no one mentioned that VMWare does not support software raids which is what the onboard raid is. I have no choice now to go with no raid on the servers.

    I can only assume that the SAN will be my fail safe anyway

    Malcolm