- Windows 2003 sp2 with all updates installed including WindowsServer2003-KB940349-v3-x86-ENU.exe
- NetWorker for Windows 7.6 sp3
- one group with one client, job started via NMC, rmb click on group then "start"
- Vss service set to manual startup.
I have strange sutuation with bootstrap backup...
1) When i configure client to backup NMC (saveset: NMCASA:/gst_on_ /lgto_gst, backup command: savepsm, all other setting untouched), backup of bootstrap is failed with error:
1 retry attempted
39078:save: RPC error: Can't encode arguments
7162:save: save of bootstrap to failed
: VSS service has stopped during a VSS save.
: File D:\Program Files\Legato\nsr\res\lgtolm.res could not be opened and was not backed up. (No error)
No any vss-related errors was found in System and Application logs, no any additional information, related to error was found in NetWorker logs.
And no events 7036 ("The Microsoft Software Shadow Copy Provider service entered the running state." and "The Volume Shadow Copy service entered the running state.") in System log was found.
2) When i configure same client to backup an folder from NetWorker server (save set: d:\Program Files\Legato, backup command: ), bootstrap is backed up successfuly, with one warning:
: File D:\Program Files\Legato\nsr\res\lgtolm.res could not be opened and was not backed up. (Permission denied)
In this case i see in Sytem logs events 7036 ("The Microsoft Software Shadow Copy Provider service entered the running state." and "The Volume Shadow Copy service entered the running state.")
If i start 1) right after 2) when vss service still not stopped, bootstrap backed up like in case 2).
Seems to bootstrap backup unable to start vss service but can use already started vss service.
This problem has already been reported by another customer (reference NW132964) and is being investigated. It looks like the problem is caused by the license manager file lgtolm.res being locked which is failing the backup. Apparently, the bootstrap doesn't use VSS to do the backup, so if the file is locked it can have problems backing it up. Is there something going on at the time that would explain why the license manager file is locked?
I think that you should look again into the Application and System event logs at the time of the backup. There should be some further information as to why the VSS service is being stopped.
I suppose that both, Volume shadow copy and Microsoft Shadow copy service are in status manual, right? that is the status that both should have.
Anyway check if you have VSS scheduled/Enabled. To see it you have to go to disk management console, and right click on any of the disks. Then select properties and open the Shadow Copy tab. If it says "Enabled" then disable it and try a new backup.
I already found article mentioned in your post, but for me is not clear, where is resolution:-))
Yes, both service set to "Manual"...
Little remark: VSS service is not stopped during failed backup, it not started when backup starts (as far as i know, VSS is on-demand starting service).
And... no any entries in App and Sys logs at the time of failed backup, only message from Networker (EventID:1, Category: Savegroup):
NetWorker savegroup: (alert) Test completed, Total 1 client(s), 1 Failed. Please see group completion details for more information.
coganb
736 Posts
1030
1
Posted February 2nd, 2012 03:00
Hi Pavel,
This problem has already been reported by another customer (reference NW132964) and is being investigated. It looks like the problem is caused by the license manager file lgtolm.res being locked which is failing the backup. Apparently, the bootstrap doesn't use VSS to do the backup, so if the file is locked it can have problems backing it up. Is there something going on at the time that would explain why the license manager file is locked?
-Bobby