Announcement Banner
UNSOLVED

wangyd

updated

18 years ago

W

wangyd

1 Rookie

•

65 Posts

0

11496

October 12th, 2008 07:00

db2 restore error,SQL2062N

backup server:nw7.4.3
OS:aix 5.3
Database:db2 9.1.0.4 fixpack4

restore error message:
SQL2062N An error occurred while accessing media "/usr/lib/libnsrdb2.o". Reason code: "11".

debug file information:
1197078#0 Sun Oct 12 22:18:43 2008 nsrdb2_full_timestamp_restore: NMDB2_WARNING: BSAQueryObject found no matches
1197078#0 Sun Oct 12 22:18:43 2008 sqluvint: NMDB2_ERROR: nsrdb2_set_restore_object()
1197078#0 Sun Oct 12 22:18:43 2008 sqluvint: NMDB2_ERROR: no matching backups found
1197078#0 Sun Oct 12 22:18:43 2008 sqluvint: NMDB2_ERROR
659996#0 Sun Oct 12 22:26:11 2008 nsrdb2_full_timestamp_restore: NMDB2_WARNING: BSAQueryObject found no matches
659996#0 Sun Oct 12 22:26:11 2008 sqluvint: NMDB2_ERROR: nsrdb2_set_restore_object()
659996#0 Sun Oct 12 22:26:11 2008 sqluvint: NMDB2_ERROR: no matching backups found
659996#0 Sun Oct 12 22:26:11 2008 sqluvint: NMDB2_ERROR

and all the client havs set the Application attribute:DB2=Database:instn1:instn2;
and the Remote Access:*@*.

but when i restore the database,it can not success。
  • wangyd

    1 Rookie

    •

    65 Posts

    4258

    0

    Posted October 12th, 2008 08:00

    I am sorry,the Application attribute:
    DB2_R=XXX(database name):inst1(instance name):nst1(instance name)
  • Hari5

    443 Posts

    4258

    0

    Posted October 13th, 2008 06:00

    Ok ... the error is related to a nsr library apparently. Would suggest that you ensure that all variables in your nmdb2 file are set in the shell environment that you are using to restore. It's probably because one of these variables are missing that your restore is aborting.

    Hope that is of some use. Have not worked much with the db2 module so I can't say for sure.
  • wangyd

    1 Rookie

    •

    65 Posts

    4258

    0

    Posted October 13th, 2008 07:00

    thanks.
    I think that have some problem with the ENV.But the error is that the NWDB2's error.

    I had mike the CFG file:
    DB2:/BIDW/NODE0000 nsrdb2sv -f /nsr/db2_cfg
    db2 backup db BIDW online LOAD /usr/lib/libnsrdb2.o options @/nsr/db2_cfg

    #If the node you are using is through a local connection, use the Instance Name.
    NSR_SERVER=backup_server_name
    NSR_CLIENT=client_name
    DB2_NODE_NAME=node_name
    DB2_ALIAS=alias_name
    #end
    DB2_VENDOR_LIB_PATH=/usr/lib/libnsrdb2.o
    DB2_OPTIONS=DB2BACKUP_TABLESPACE,DB2BACKUP_ONLINE
    DB2_TBS_LIST=SYSCATSPACE
    #nsrdb2sv -f /nsr/db2_cfg -P password
    DB2_USR=user_name
    DB2_PSWD=password

    and all of the client Remote Access is:*@*
    Application information:DB2_R=Database_name:inst1:inst2

    and I had recover a file of filesystem(not database data),it can be redirect to another computer.

    With the suspicion with the networker module for db2 2.1 build 261,so I update the module with hotfix for LGTpa91317,But the error is the same.

    So,I change the networker module is 1.6 with both the client and the recoverd client.The error as following:
    SQL2542N No match for a database image file was found based on the source database alias "alias_name" and timestamp "20081013182509" provided.

    the restore command(networker module for db2 2.1):
    db2 "restore database bidw rebuild with tablespace(SYSCATSPACE) load /usr/lib/libnsrdb2.o options @/nsr/db2_cfg taken at 20081012165644 on /db2sys_res without prompting

    Has anybody solved a problem like that?
  • Hari5

    443 Posts

    4258

    0

    Posted October 13th, 2008 08:00

    Would also suggest ensuring that the time and time zone on your backup server and db2 client are in sync. Any difference in these will cause havoc with the timestamp value.
  • Hari5

    443 Posts

    4258

    0

    Posted October 13th, 2008 08:00

    Looks like you are trying to restore a particular tablespace. As I mentioned earlier, I haven't done much with db2 so I might be talking nonsense. If it helps, I found this in the db2 module admin guide.

    You can restore a database or tablespace to a particular point-in-time:
    ◆ If the database is enabled for roll-forward restore by setting the
    logarchmeth1 configuration parameter. For example:
    logarchmeth1=VENDOR:/usr/lib/libnsrdb2.xx
    Where xx is the suffix information for the libnsrdb2 command.
    For details, see Table 6-1, Path and suffix for the libnsrdb2 libraries.
    ◆ If you created log backups.


    Also found the following explanation for the error code you mentioned;

    Error Code: SQL2062N An error occurred while accessing media "/usr/lib/libnsrdb2.so".
    Reason code:"11".

    Explanation: A valid timestamp for the object being restored was not specified.

    Fix: Specify a valid timestamp.

    Would suggest you ensure that your timestamp is correct. It can be verified by the following command.

    db2 list history backup all for SAMPLE

    Where SAMPLE is the name of the database.
  • wangyd

    1 Rookie

    •

    65 Posts

    4258

    0

    Posted October 13th, 2008 08:00

    Hari,thanks.
    I know that.And I had set the log extent.
  • wangyd

    1 Rookie

    •

    65 Posts

    4258

    0

    Posted October 13th, 2008 08:00

    I think this is not the question,because i had use the nsinfo command to find the backups time stamp of DB2:
    nsrinfo -s backupserver_name -n db2 -X all client_name|grep 20081013|grep NODE0000
  • 4258

    0

    Posted April 16th, 2018 07:00

    Cause

    The user performing the backup does not have permissions on /nsr/applogs directory. The permissions on

    this directory must be set to 777.

    Same is true for other modules like NMO, etc.

    Resolution

    Please run chmod 777 /nsr/applogs.

    Knowledge Base Article: 000392765