Announcement Banner

polska14

updated

18 years ago

P

polska14

79 Posts

0

2892

September 10th, 2008 09:00

VMWare VCB and Networker

The NW admin guide say:
"To backup VMware clients using VCB with NetWorker software, the following must be installed on the VCB proxy:
◆ NetWorker client and storage node software.
◆ VMware Consolidated Backup 1.0.x
◆ The NetWorker integration module, supplied by VMware."

My question is: Can the Networker Server be the proxy?

Regards
  • ble1

    6 Operator

    •

    14354 Posts

    •

    56186 Points

    800

    0

    Posted September 24th, 2008 04:00

    In my case proxy was storage node. Storage node or server - not much difference when it comes to VCB as far as I know. Obviously I would not use server as I would like to keep it dedicated as backup server only.
  • andreas.scht

    2 Intern

    •

    219 Posts

    800

    0

    Posted September 11th, 2008 02:00

    I think when the server is a Windows 2003 Server then it should be run.

    VCB Proxy have to be a Windows Server!!!
  • zenariga

    54 Posts

    800

    1

    Posted September 11th, 2008 05:00

    Hello,

    I used a Networker server to be a Proxy server, but I have problems. In matrix of VMWare the recommended version is 7.4.1. I try to use this version but networker don't index the vcb backup. Using the version 7.4.0 works but my server stay outdated and I lost many advantages of 7.4.2 Server Version.

    I solve this problem creating a Virtual Proxy, is this virtual machine I install the Consolidated Backup, the Legato Integrator and the Networker version 7.4.0, and my server stay with the last and updated version. I add this client in my networker server and use this how proxy backup.

    Is the simple way to solve my problem.

    This is a config.js file from my client. When you configure a virtual machine works how VBC proxy you need to enable and change the TRANSPORTATION MODE from "san" to "nbd".

    If you need more help to understand the environment, I help you.

    /*
    * Generic configuration file for VMware Consolidated Backup (VCB).
    */

    /*
    * Directory where all the VM backup jobs are supposed to reside in.
    * For each backup job, a directory with a unique name derived from the
    * backup type and the VM name will be created here.
    * If omitted, BACKUPROOT defaults to c:\\mnt.
    *
    * Make sure this directory exists before attempting any VM backups.
    */
    BACKUPROOT="V:\\";

    /*
    * URL that is used by "mountvm" to obtain the block list for a
    * disk image that is to be mounted on the backup proxy.
    *
    * Specifying this option is mandatory. There is no default
    * value.
    */
    HOST="bermejo.educacao.intragov";

    /*
    * Port for communicating with all the VC SDK services.
    * Defaults to 443
    */
    // PORT="443";

    /*
    * Username/password used for authentication against the mountvm server.
    * Specifying these options is mandatory.
    */
    USERNAME="xxx";
    PASSWORD="xxx";

    /*
    * TRANSPORT_MODE determines how VCB accesses virtual disk data.
    * Currently, two modes are supported on Windows:
    *
    * +) "san"
    * Virtual disk data is read directly off a shared storage device
    * that that the virtual disk resides on. This requires VMFS
    * storage on SAN or iSCSI and the storage device has to be
    * accessible from both ESX and the VCB proxy.
    * +) "nbd"
    * In this mode, VCB will use an over-the-network protocol to
    * access the virtual disk. Data is read from the storage device by
    * the ESX host and then sent across an unencrypted network channel
    * to the VCB proxy.
    * Please note that this mode does not provide the offload
    * capabilities of the "san" mode (since data is still transferred
    * from the ESX host across the network). However, "nbd" does not
    * require shared storage and also enables VCB to be run inside a
    * virtual machine.
    * +) "nbdssl"
    * This mode is same as "nbd" except that the data transfered over
    * the network is encrypted. The data transfer in "nbdssl" mode can
    * be slower and use more CPU than in the "nbd" transport mode. The
    * "nbdssl" mode will fail when connecting directly to ESX 3.0.x
    * or VC 2.0.x host.
    *
    * The default option is "san".
    */
    TRANSPORT_MODE="nbd";

    /*
    * The log level determines the amount of log output generated by VCB.
    * Valid ranges are from 0 (least verbose) to 6 (most verbose), with a
    * default setting of 3. Change this setting to 6 when troubleshooting.
    */
    LOGLEVEL=6;

    /*
    * SNAPSHOT_POLICY determines how disk snapshots for backup are being created:
    * +) "automatic"
    * A snapshot is being generated automatically by the Interoperability
    * Module right before backup and it is being removed
    * automatically right after backup.
    * +) "manual" -
    * Exactly one snapshot named "_VCB-BACKUP_" must already exist for
    * each protected VM. The snapshot is mounted/unmounted on the proxy,
    * but the snapshot is neither created nor deleted by VCB.
    * This can be used to have external tools manage the backup snapshot.
    * +) "createonly"
    * The Interoperability Module will create the snapshot for each VM
    * right before it gets backed up, but will not remove the snapshot
    * after unmounting.
    * +) "deleteonly"
    * The Interoperability Module assumes that the snapshot named
    * "_VCB-BACKUP_" has been created beforehand. The snapshot will be
    * deleted automatically after backup.
    *
    * The default option is "automatic"
    *
    */
    //SNAPSHOT_POLICY="automatic";

    /*
    * The criteria to be used to identify a virtual machine
    *
    * +) ipaddr
    * VMs are looked up based on their DNS name/IP address.
    * +) name
    * VMs are looked up based on their name as shown in VirtualCenter.
    * Note that backup will fail for VMs with non-unique names.
    *
    * The default option is "ipaddr". You should only change this
    * if you have multiple sets of VMs with the same IP address, but with
    * different names.
    */
    VM_LOOKUP_METHOD="name";


    /*
    * Behavior for a backup job when the VM mount point already exists.
    *
    * +) fail
    * A pre-existing mountpoint is causing a backup job to fail
    * +) delete
    * Attempt to remove the pre-existing mount point (and backup
    * snapshots associated with it). If this op. fails, fail
    * the backup job.
    *
    * The default option is "fail"
    */
    PREEXISTING_MOUNTPOINT="delete";


    /*
    * Behavior for backup job when a previous backup snapshot of a virtual
    * machine already exists.
    *
    * +) fail
    * A pre-existing backup snapshot is causing a backup job to fail
    * +) delete
    * Attempt to delete the pre-existing backup snapshot. If the
    * backup snapshot can be deleted without errors, proceed with
    * the backup job. Otherwise fail the backup job.
    *
    * the default option is "fail"
    */
    PREEXISTING_VCB_SNAPSHOT="delete";

    /*
    * Number of times an operation is re-tried after it fails.
    * You might want to use this option if you see a large number
    * of backup jobs fail with "resource busy" errors.
    *
    * Usually, backup software will retry failed jobs, but it
    * might be hours until the backup software retries.
    *
    * By default, retry is disabled (set to 0).
    */
    //MAX_RETRIES=0;

    /*
    * Number of seconds to wait before retrying a failed
    * operation. The default value is 10 seconds.
    *
    * If you change this default, you probably also want to change
    * the default for MAX_RETRIES (since this setting only matters
    * if MAX_RETRIES is larger than 0).
    */
    //BACKOFF_TIME=10;

    Thanks!
  • polska14

    79 Posts

    800

    0

    Posted September 15th, 2008 04:00

    Thank you, but the customer needs to complete the VCB backup via SAN. Obviously, he can't use a virtual machine to realize that.
  • polska14

    79 Posts

    800

    0

    Posted September 16th, 2008 08:00

    Do you have some installation with this configuration?
    Regards.
  • Guru4

    19 Posts

    800

    0

    Posted November 25th, 2008 12:00

    Hello,
    Does any one have complete VCB setup guide for review, i would recommend Storage node as VCB proxy strongly , unless you are using over the network method so that backups are directed over local tape drives and are more efficiant