UNSOLVED

jmarshak

updated

19 years ago

J

jmarshak

11 Posts

0

1506

June 4th, 2007 09:00

SanCopy Errors in RM5.0.2

I just upgraded from RM4 to RM5.0.2. My old application sets and jobs were not as clean as I would have liked so I deleted everything down to the storage and recreated the application sets, storage pools, jobs, and schedules (no big deal, I only have a dozen or so).

SnapView snaps are working great.

Some of my SanCopy incremental jobs work fine, but two of them (one is NTFS source, the other is SQL2000) consisently error like this:

2007 06 02 12:17:15 mail03b 000033 ERROR: Function dcSANCopyMarkSessions failed.
2007 06 02 12:17:15 mail03b 000618 ERROR: Replication Manager was unable to unmark the Incremental SAN Copy session clariion_RMINC-APM00012345678_0030-061116130145 on array APM00012345678.

Note that the initial SanCopy incremental session went without error.

Any suggestions appreciated!

Jake

Message was edited by:
primoprimus
  • JamesBEMC

    257 Posts

    325

    1

    Posted June 5th, 2007 05:00

    Hi Jake

    Is there any pattern to the failures? ie only Windows 2000 hosts affected?
    Did you also upgrade the Flare code on the Clariion?

    You may want to read the EMC KnowledgeBase solution emc161580 on Powerlink.

    If you are still in trouble, please open an EMC SR and we'll investigate for you.

    Cheers
    James
  • jmarshak

    11 Posts

    325

    0

    Posted June 5th, 2007 09:00

    James, thanks for the reply.

    All the hosts (those that are working and those that are having issues) are Windows 2003 Enterprise Edition SP1.

    Yes we did upgrade to Flare 24 back in Feb 07 (as well as all the host based software to .24; admsnap, navicli, naviagent,etc) based on recommendation from Support to resolve a queued I/O problem we were having on the CX.

    I took a look at emc161580 and we are running Solutions Enabler 6.4.0.5 on all the hosts, so I don't think that is related even though the log entries look similar. I may try Solutions Enabler 6.3.2.20 on one of the hosts just too see if that makes a difference.

    If you think of anything else, please let me know. Otherwise it's off to Support!

    Thanks again,

    Jake
  • JamesBEMC

    257 Posts

    325

    0

    Posted June 6th, 2007 00:00

    Hi Jake,

    Funnily enough I just had a call with this exact error for consistently failing Sancopy jobs after upgrading to RM 5.0.2 (and upgrading navi agent/cli, etc). All hosts except this host was working for Incr Sancopy.

    I fixed (at least this particular instance of the error) it by addding in the required entries in the Navisphere agent's agent.config file. The host had a blank agent.config.
    Typically C:\Program Files\emc\navisphere agent\agent.config
    I added the required lines, eg

    user (username)@spA
    user (username)@spB
    user system@spA
    user system@spB

    (The user will need to be the same as all the other users in the RM configuration to ensure the clariion authorization works.)

    Restart Naviagent service and then Replication Manager Client service.
    Try your Incr sancopy job again.


    Let me know how it goes for you.

    Best of luck,
    James.
  • dima

    1 Message

    325

    1

    Posted June 7th, 2007 11:00

    Got exact same issue. Running FLARE 24 and upgraded to RM5 Sp2. Tried agent config file, and solution en 6.3.2.20 - no luck. The odd thing is that jobs are failing RANDOMLY. Meaning the same job may fail and then work again.
  • jmarshak

    11 Posts

    325

    0

    Posted June 9th, 2007 19:00

    Yep, dima, I am seeing the same thing now that it has been running on 5.0.2 for a week. About 1/3 failure rate randomly.

    I've double checked versions and agent.config settings on all hosts.

    Do you see the same error everytime it fails? Mine is always the same as my first post.
  • jmarshak

    11 Posts

    325

    0

    Posted June 9th, 2007 19:00

    Agent.configs all look correct to me. Each host's agent.config includes any CX SPs that the host is zoned to see.

    Not all hosts can see the remote SanCopy destination array, so those SPs aren't listed in the agent.config.
  • JamesBEMC

    257 Posts

    325

    0

    Posted June 12th, 2007 10:00

    Are ye guys making sure you are using the same username and password for the navi authentication for all RM clients?

    The other thing my customer had was 1 client using Username X for navi authentication and username Y for RM authentication to the array.
  • JamesBEMC

    257 Posts

    325

    0

    Posted June 17th, 2007 23:00

    Guys,

    We had another customer who had this issue and they opened a call with us and engineering have identified the problem in the RM Code, which is due to the new Flare 24 single management interface design.

    As long as your issue can be confirmed to be the same, there is a hotfix available for you. If you open a Service Request and ask for Hotfix 31704 for RM 5.0.2, it will resolve your problem.

    If you search using the Windows Search option;
    for "files containing the following words"
    in the RM Client debug logs directory on the production or local mount host (C:\program Files\emc\rm\logs\client\)

    and find the following;
    main. CLAR Err: Error returned from Agent
    main.
    CLAR Err: This command was sent to the SP that does not own the lun (0x71008043)

    Then you can confirm it is the same issue and the hotfix will resolve this.

    Thanks
    James.
  • drozz

    77 Posts

    325

    0

    Posted July 3rd, 2007 07:00

    This is also happening to my setup after a new RM 5.0.2 install. I am waiting for the HotFix # 31704 to fix the way the naviseccli interprets the owner information in the listsessions output. If you have the jobs retry about 3 times in 60 second intervals, they will eventually grab the proper SP and the jobs will complete. This shouldn't be a permanent fix but will get you through till you receive the HotFix.
  • JamesBEMC

    257 Posts

    117

    0

    Posted July 5th, 2007 02:00

    Hi Drozz,

    I put the RM 5.0.2 hotfix on ftp://ftp.emc.com/incoming/31704 for you.

    Please ensure to read the readme.

    Thanks