You are about to HALT this Celerra including all of its Control Stations and Data Movers. DATA will be UNAVAILABLE when the system is halted. Note that this command does *not* halt the storage array.
ARE YOU SURE YOU WANT TO CONTINUE? [ yes or no ] : yes Sending the halt signal to the Master Control Daemon...: Done Nov 6 15:07:02 EMC-MKHRI EMCServer: nas_mcd: Check and halt other CS...: Done Nov 6 15:07:09 EMC-MKHRI EMCServer: ReportEvent: CCMD 95026741253:CS_CORE(2):CommandService(9):INFO(6):5 Nov 6 15:07:33 EMC-MKHRI JSERVER: *** Java Server is exiting *** Nov 6 15:07:36 EMC-MKHRI mcd_helper: Cleaned up old APL share memory 0 Nov 6 15:07:36 EMC-MKHRI mcd_helper: Cleaned up old APL semaphores 0 32769 65538 Nov 6 15:07:37 EMC-MKHRI setup_enclosure: Executing -dhcpd stop option Nov 6 15:07:38 EMC-MKHRI snmptrapd[9838]: Stopping snmptrapd Nov 6 15:07:39 EMC-MKHRI mcd_helper: starting nas_lvm_tool Nov 6 15:07:42 EMC-MKHRI mcd_helper: nas_lvm_tool completed successfully. Nov 6 15:08:06 EMC-MKHRI kernel: kjournald starting. Commit interval 5 seconds Nov 6 15:08:06 EMC-MKHRI kernel: EXT3 FS on nde1, internal journal Nov 6 15:08:06 EMC-MKHRI kernel: EXT3-fs: mounted filesystem with ordered data mode. Nov 6 15:08:10 EMC-MKHRI kernel: kjournald starting. Commit interval 5 seconds Nov 6 15:08:10 EMC-MKHRI kernel: EXT3 FS on hda5, internal journal Nov 6 15:08:10 EMC-MKHRI kernel: EXT3-fs: mounted filesystem with ordered data mode. Nov 6 15:08:21 EMC-MKHRI mcd_helper: starting nas_lvm_tool Nov 6 15:08:22 EMC-MKHRI mcd_helper: nas_lvm_tool completed successfully. Nov 6 15:08:23 EMC-MKHRI mcd_helper: starting nas_lvm_tool Nov 6 15:08:24 EMC-MKHRI DHCPDMON: Starting DHCPD on CS 0 Nov 6 15:08:25 EMC-MKHRI setup_enclosure: Executing -dhcpd start option Nov 6 15:08:25 EMC-MKHRI dhcpd: Internet Systems Consortium DHCP Server V3.0.1 Nov 6 15:08:25 EMC-MKHRI dhcpd: Copyright 2004 Internet Systems Consortium. Nov 6 15:08:25 EMC-MKHRI dhcpd: All rights reserved. Nov 6 15:08:25 EMC-MKHRI dhcpd: For info, please visit http://www.isc.org/sw/dhcp/ Nov 6 15:08:25 EMC-MKHRI dhcpd: Wrote 0 deleted host decls to leases file. Nov 6 15:08:25 EMC-MKHRI dhcpd: Wrote 0 new dynamic host decls to leases file. Nov 6 15:08:25 EMC-MKHRI dhcpd: Wrote 0 leases to leases file. Nov 6 15:08:25 EMC-MKHRI dhcpd: Listening on LPF/eth2/00:15:17:92:0a:3f/128.221.253.0/24 Nov 6 15:08:25 EMC-MKHRI dhcpd: Sending on LPF/eth2/00:15:17:92:0a:3f/128.221.253.0/24 Nov 6 15:08:25 EMC-MKHRI dhcpd: Listening on LPF/eth0/00:15:17:8d:a3:52/128.221.252.0/24 Nov 6 15:08:25 EMC-MKHRI dhcpd: Sending on LPF/eth0/00:15:17:8d:a3:52/128.221.252.0/24 Nov 6 15:08:25 EMC-MKHRI dhcpd: Sending on Socket/fallback/fallback-net Nov 6 15:08:25 EMC-MKHRI dhcpd: bogus UDP packet length: 23929 Nov 6 15:08:25 EMC-MKHRI dhcpd: bogus UDP packet length: 23929 Nov 6 15:08:25 EMC-MKHRI dhcpd: bogus UDP packet length: 53504 Nov 6 15:08:38 EMC-MKHRI mcd_helper: nas_lvm_tool completed successfully. Nov 6 15:08:38 EMC-MKHRI mcd_helper: starting nas_lvm_tool Nov 6 15:08:40 EMC-MKHRI kernel: kjournald starting. Commit interval 5 seconds Nov 6 15:08:40 EMC-MKHRI kernel: EXT3 FS on dm-1, internal journal Nov 6 15:08:40 EMC-MKHRI kernel: EXT3-fs: mounted filesystem with ordered data mode. Nov 6 15:08:40 EMC-MKHRI kernel: kjournald starting. Commit interval 5 seconds Nov 6 15:08:40 EMC-MKHRI kernel: EXT3 FS on dm-4, internal journal Nov 6 15:08:40 EMC-MKHRI kernel: EXT3-fs: mounted filesystem with ordered data mode. Nov 6 15:08:40 EMC-MKHRI kernel: kjournald starting. Commit interval 5 seconds Nov 6 15:08:40 EMC-MKHRI kernel: EXT3 FS on dm-5, internal journal Nov 6 15:08:40 EMC-MKHRI kernel: EXT3-fs: mounted filesystem with ordered data mode. Nov 6 15:08:40 EMC-MKHRI kernel: kjournald starting. Commit interval 5 seconds Nov 6 15:08:40 EMC-MKHRI kernel: EXT3 FS on dm-6, internal journal Nov 6 15:08:40 EMC-MKHRI kernel: EXT3-fs: mounted filesystem with ordered data mode. Nov 6 15:08:40 EMC-MKHRI kernel: kjournald starting. Commit interval 5 seconds Nov 6 15:08:40 EMC-MKHRI kernel: EXT3 FS on dm-7, internal journal Nov 6 15:08:40 EMC-MKHRI kernel: EXT3-fs: mounted filesystem with ordered data mode. Nov 6 15:08:40 EMC-MKHRI kernel: kjournald starting. Commit interval 5 seconds Nov 6 15:08:40 EMC-MKHRI kernel: EXT3 FS on dm-8, internal journal Nov 6 15:08:40 EMC-MKHRI kernel: EXT3-fs: mounted filesystem with ordered data mode. Nov 6 15:08:41 EMC-MKHRI kernel: kjournald starting. Commit interval 5 seconds Nov 6 15:08:41 EMC-MKHRI kernel: EXT3 FS on dm-9, internal journal Nov 6 15:08:41 EMC-MKHRI kernel: EXT3-fs: mounted filesystem with ordered data mode. Nov 6 15:08:41 EMC-MKHRI kernel: kjournald starting. Commit interval 5 seconds Nov 6 15:08:41 EMC-MKHRI kernel: EXT3 FS on dm-10, internal journal Nov 6 15:08:41 EMC-MKHRI kernel: EXT3-fs: mounted filesystem with ordered data mode. Nov 6 15:08:41 EMC-MKHRI mcd_helper: nas_lvm_tool completed successfully. Nov 6 15:08:41 EMC-MKHRI EMCServer: nas_mcd: Quiescing the servers in preparation for halt... Nov 6 15:08:52 EMC-MKHRI EMCServer: nas_mcd: Quiescing :Succeeded Nov 6 15:08:54 EMC-MKHRI mcd_helper: starting nas_lvm_tool Nov 6 15:08:57 EMC-MKHRI mcd_helper: nas_lvm_tool completed successfully. Nov 6 15:08:57 EMC-MKHRI EMCServer: nas_mcd: Halting all servers...
Mounting sysfs Copyright(c) 2003-2007 Emulex. All rights reserved.
Creating /dev Starting udev Loading sd_mod.koEXT3-fs: INFO: recovery required on readonly filesystem. module LoadingEXT3-fs: write access will be enabled during recovery. aic7xxx.ko module Loading scsi_transport_fc.ko module Loading qla2xxx.ko module Loading qla2200.ko module Loading lpfc.ko module Creating root device Mounting root filesystem EXT3-fs: recovery complete. kjournald starting. Commit interval 5 seconds EXT3-fs: mounted filesystem with ordered data mode. Switching to new root
INIT: version 2.85 bootingSetting default font (latarcyrheb-sun16): [ OK ] Welcome to EMC Celerra Control Station Linux Press 'I' to enter interactive startup. Starting udev: [ OK ]Initializing hardware... storage network audio done[ OK ]Configuring kernel parameters: [ OK ]Setting clock (localtime): Sat Nov 6 15:13:22 JST 2010 [ OK ]Loading default keymap (us): [ OK ]Setting hostname EMC-MKHRI: [ OK ]Your system appears to have shut down uncleanly
Press Y within 5 seconds to force file system integrity check... Press Y within 4 seconds to force file system integrity check... Press Y within 3 seconds to force file system integrity check... Press Y within 2 seconds to force file system integrity check... Press Y within 1 seconds to force file system integrity check... Checking root filesystem [/sbin/fsck.ext3 (1) -- /] fsck.ext3 -a /dev/hda3 / has gone 351 days without being checked, check forced. /: 29995/262144 files (1.0% non-contiguous), 253462/524120 blocks [ OK ]Remounting root filesystem in read-write mode: [ OK ]Setting up Logical Volume Management: [ OK ]Checking filesystems Checking all file systems. [/sbin/fsck.ext3 (1) -- /boot] fsck.ext3 -a /dev/hda1 /boot: recovering journal /boot has gone 351 days without being checked, check forced. /boot: 35/32128 files (2.9% non-contiguous), 12847/128488 blocks [ OK ]Mounting local filesystems: [ OK ]Enabling local filesystem quotas: [ OK ]Enabling swap space: [ OK ]
INIT: Entering runlevel: 3Entering non-interactive startup Applying Intel Microcode update: [ OK ]Starting sysstat: [ OK ]Applying iptables firewall rules: [ OK ]Setting network parameters: [ OK ]Bringing up loopback interface: [ OK ]Bringing up interface eth0: [ OK ]Bringing up interface eth1: [ OK ]Bringing up interface eth2: [ OK ]Bringing up interface eth3: [ OK ]Starting system logger: [ OK ]Starting kernel logger: [ OK ]Starting portmap: [ OK ]Starting NFS statd: [ OK ]Starting RPC idmapd: [ OK ]Mounting other filesystems: [ OK ]Starting lm_sensors: [ OK ]Starting automount: [ OK ]Starting smartd: [ OK ]Starting sshd:[ OK ]Starting xinetd: [ OK ]ntpd: Synchronizing with time server: [ OK ]Starting ntpd: [ OK ]Starting sendmail: [ OK ]Starting sm-client: [ OK ]Starting crond: [ OK ]Starting nbs: nd_mod: module license 'unspecified' taints kernel. [ OK ]Starting nsxbmc: [ OK ]Starting process accounting: [ OK ]Starting localemc: [ OK ]Starting anacron: [ OK ]Starting atd: [ OK ]Starting system message bus: [ OK ]Starting HAL daemon: [ OK ] The EMC(C) version of Linux(C), used as the operating system on the Celerra(TM) Control Station(s), is a customized version of Linux. The operating system is copyrighted and licensed pursuant to the GNU General Public License ("GPL"), a copy of which can be found in the accompanying documentation. Please read the GPL carefully, because by using the Linux operating system on the EMC Celerra you agree to the terms and conditions listed therein.
EXCEPT FOR ANY WARRANTIES WHICH MAY BE PROVIDED UNDER THE TERMS AND CONDITIONS OF THE APPLICABLE WRITTEN AGREEMENTS BETWEEN YOU AND EMC, THE SOFTWARE PROGRAMS ARE PROVIDED AND LICENSED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. In no event will EMC Corporation be liable to you or any other person or entity for (a) incidental, indirect, special, exemplary or consequential damages or (b) any damages whatsoever resulting from the loss of use, data or profits, arising out of or in connection with the agreements between you and EMC, the GPL, or your use of this software, even if advised of the possibility of such damages.
"EMC" is a registered trademark of EMC Corporation, and "Linux" is a registered trademark of Linus Torvalds. "Celerra" is a trademark of EMC.
EMC Celerra Control Station Linux release 2.0 (NAS 5.6.46) EMC-MKHRI login: root Password: Last login: Sat Nov 6 15:05:18 on ttyS1 EMC Celerra Control Station Linux Fri Nov 20 03:54:25 EST 2009 You have new mail. [root@EMC-MKHRI ~]# /nasmcd/sbin/nas_halt now
You are about to HALT this Celerra including all of its Control Stations and Data Movers. DATA will be UNAVAILABLE when the system is halted. Note that this command does *not* halt the storage array.
ARE YOU SURE YOU WANT TO CONTINUE? [ yes or no ] : yes Sending the halt signal to the Master Control Daemon...: Done Nov 6 15:18:23 EMC-MKHRI EMCServer: ReportEvent: CCMD 87518412811:CS_PLATFORM(6):MasterControl(129):WARNING(4):11, ARGs:string(8):'127.0.0.1', ARG1:string(8):'haltserversandcs', ARG0:string(8):'exec' Nov 6 15:18:24 EMC-MKHRI nd-clnt: Connect to server_2 port 5033 failed Nov 6 15:18:24 EMC-MKHRI last message repeated 2 times Nov 6 15:18:26 EMC-MKHRI EMCServer: ReportEvent: CCMD 87518412801:CS_PLATFORM(6):MasterControl(129):WARNING(4):1 Nov 6 15:18:48 EMC-MKHRI nd-clnt: Connect to server_3b port 5033 failed Nov 6 15:18:48 EMC-MKHRI last message repeated 2 times Nov 6 15:19:10 EMC-MKHRI mcd_helper: NBS device(s) not available yet... Nov 6 15:19:13 EMC-MKHRI nd-clnt: Connect to server_2b port 5033 failed Nov 6 15:19:13 EMC-MKHRI last message repeated 2 times Nov 6 15:19:39 EMC-MKHRI nd-clnt: Connect to server_3 port 5033 failed Nov 6 15:19:39 EMC-MKHRI last message repeated 2 times Nov 6 15:20:06 EMC-MKHRI nd-clnt: Connect to server_2 port 5033 failed Nov 6 15:20:06 EMC-MKHRI last message repeated 2 times Nov 6 15:20:10 EMC-MKHRI mcd_helper: NBS device(s) not available yet... Nov 6 15:20:34 EMC-MKHRI nd-clnt: Connect to server_3b port 5033 failed Nov 6 15:20:34 EMC-MKHRI last message repeated 2 times Nov 6 15:21:03 EMC-MKHRI nd-clnt: Connect to server_2b port 5033 failed Nov 6 15:21:03 EMC-MKHRI last message repeated 2 times Nov 6 15:21:10 EMC-MKHRI mcd_helper: NBS device(s) not available yet... Nov 6 15:21:33 EMC-MKHRI nd-clnt: Connect to server_3 port 5033 failed Nov 6 15:21:33 EMC-MKHRI last message repeated 2 times Nov 6 15:22:04 EMC-MKHRI nd-clnt: Connect to server_2 port 5033 failed Nov 6 15:22:04 EMC-MKHRI last message repeated 2 times Nov 6 15:22:10 EMC-MKHRI mcd_helper: NBS device(s) not available yet... Nov 6 15:22:36 EMC-MKHRI nd-clnt: Connect to server_3b port 5033 failed
Nov 6 15:22:36 EMC-MKHRI last message repeated 2 times Nov 6 15:23:09 EMC-MKHRI nd-clnt: Connect to server_2b port 5033 failed Nov 6 15:23:09 EMC-MKHRI last message repeated 2 times Nov 6 15:23:10 EMC-MKHRI mcd_helper: NBS device(s) not available yet... Nov 6 15:23:43 EMC-MKHRI nd-clnt: Connect to server_3 port 5033 failed Nov 6 15:23:43 EMC-MKHRI last message repeated 2 times Nov 6 15:24:10 EMC-MKHRI mcd_helper: NBS device(s) not available yet... Nov 6 15:24:18 EMC-MKHRI nd-clnt: Connect to server_2 port 5033 failed Nov 6 15:24:18 EMC-MKHRI last message repeated 2 times Nov 6 15:24:54 EMC-MKHRI nd-clnt: Connect to server_3b port 5033 failed Nov 6 15:24:54 EMC-MKHRI last message repeated 2 times Nov 6 15:25:10 EMC-MKHRI mcd_helper: NBS device(s) not available yet...
Nov 6 15:25:31 EMC-MKHRI nd-clnt: Connect to server_2b port 5033 failed
[root@EMC-MKHRI ~]#
[root@EMC-MKHRI ~]# /sbin/halt Broadcast meStopping HAL daemon: [ OK ]Stopping system message bus: [ OK ]Stopping atd: [ OK ]Shutting down process accounting: [ OK ]Stopping sshd:[ OK ]Shutting down sm-client: [ OK ]Shutting down sendmail: [ OK ]Shutting down smartd: [ OK ]Stopping xinetd: [ OK ]Stopping crond: [ OK ]Stopping autofs: [ OK ]Shutting down ntpd: [ OK ]Stopping nas: starting nas_lvm_tool Command Error: the command '/usr/sbin/lvchange -an /dev/emc_vg_lun_0/emc_lv_nbsnas_jserver' failed with return code = 5 The following output was returned: /dev/nda1: open failed: No such device or address /dev/nda3: open failed: No such device or address Volume group "emc_vg_lun_0" not found
nas_lvm_tool encountered a fatal error. [FAILED]Stopping nbs: cat: /proc/driver/nd/devices/*: No such file or directory [ OK ]Stopping NFS statd: [ OK ]Stopping portmap: [ OK ]Shutting down kernel logger: [ OK ]Shutting down system logger: [ OK ]Shutting down interface eth0: [ OK ]Shutting down interface eth1: [ OK ]Shutting down interface eth2: [ OK ]Shutting down interface eth3: [ OK ]Shutting down loopback interface: [ OK ]Disabling IPv4 packet forwarding: [ OK ]Stopping iptables: [ OK ]Stopping sysstat: [ OK ]Starting killall: [ OK ]Sending all processes the TERM signal... Sending all processes the KILL signal... Saving random seed: Syncing hardware clock to system time Stopping software watchdog: Turning off swap: Turning off quotas: Unmounting pipe file systems: Unmounting file systems: Halting system... md: stopping all md devices. md: md0 switched to read-only mode. Shutdown: hda System halted.
Exactly. Your major concern must be to gracefuly shutdown the Data Movers. Once they are halted, you can safely shutdown the control station, and power off the system.
gbarretoxx1
2 Intern
•
366 Posts
1665
0
Posted November 8th, 2010 17:00
Exactly. Your major concern must be to gracefuly shutdown the Data Movers. Once they are halted, you can safely shutdown the control station, and power off the system.
Gustavo Barreto.