Announcement Banner
UNSOLVED

paulo3

updated

9 years ago

P

paulo3

2 Intern

•

202 Posts

0

2242

February 13th, 2018 13:00

db2 restore fails from command line (SQL2025N)

Dear Experts!

We are using NW 9.1 and DD2500.We have some linux clients which are backing up db2 data to the

DD via Ethernet boost.The server is Windows server, the boost devices are mounted on the server.

The clients are RH linux clients.The db2 backup is running fine.

I want to restore a db2 database from command line, but it fails with the following error:

# db2 restore db DBNAME load /usr/lib/libnsrdb2.so open 1 sessions options @/nsr/apps/config/nmda_db2_inst2.cfg

SQL2025N  An I/O error occurred. 

Error code: "25". Media on which this error occurred: "VENDOR".

On the NW side, i observed that restore process is started and its progress is 0%.

# db2 list backup

On the client is running smoothly without error.There is no usable messages in xbsa and messages

files.

Questions:

- Serveral knowledge base mention this error but i dont find a good solution.

  Do you have any suggestions and recommendations in this case?

- Should i have to set up NW enviromental vars or i is enough in nmda_db2 config file?

Thank you for sharing ideas.

BR:

Pal Szabo

No Responses