I've tried installing clients 7.5.1, 7.6.1 and 7.6.2 on a CentOS 5.6 box in our environment. We have plenty of other Red Hat and a few CentOS boxes backup up without a problem.
The install runs fine. When I start networker 7.6.1 or 7.5.1 there are no errors. When I start 7.6.2 there's a warning about the random number generator.
In any case, the nsrexecd process does not start, or immediately stops -- it's definitely not running long enough to see it in ps. The only error is in /nsr/logs/daemon.raw, which says the following:
nsrexecd SYSTEM error: Unable to register 390436 version 1 on tcp. Aborting
nsrexecd Cannot start authserver (or Cannot start authentication server for 7.6.2)
I'm not even sure where else to look for errors. There's nothing in the regular logs (/var/log) that's interesting.
I'm completely willing to downgrade or upgrade Centos, this box is just a file server so the version isn't important.
Also please note I'm not the networker admin, but I can yell at him from my cube if there are question about the overall system. All our other backups are running normally, so I'm pretty sure it's specific to this box.
Sorry if I wasn't clear -- in ALL versions I've tried, the service will not start. 7.6.2 issues a warning at the console when started, and the others do not. However, none of them actually start the service.
Unfortunately I will probably have to rebuild the system and try it again or try a different OS if no one else has any ideas.
It may be a portmap or networking issue. Comparing the same command run on a known good installation (on RHEL 5), it seems to fail right after binding to the ipv4 socket.
The only other difference is that this machine doesn't have ipv6 enabled, and the working RHEL5 machine does. I can try enabling that for laughs, but it'll require a reboot and I won't be able to do that until after hours.
Holy moly you're my hero. The hosts file was hosed -- it only had the ipv6 loopback address (ipv6 wasn't enabled) and no 127.0.0.1 entry. I blame the CentOS installer
bingo.1
1 Rookie
•
2430 Posts
1074
0
Posted August 9th, 2011 14:00
There should not be any issue. In your case, i would open a SR.
However, using an older NW version for the client is not an issue. So you have a workaround until the problem will be fixed.