UNSOLVED

Priam2

updated

12 years ago

P

Priam2

11 Posts

0

967

June 16th, 2014 16:00

snmpd hidden user?

While upgrading my NS-120 I saw the step "configure snmpd hidden user". What purpose does the hidden user serve? And who's it hidden from? Me? Sounds...suspicious...

Thanks!

  • Rainer_EMC

    6 Operator

    •

    8645 Posts

    573

    0

    Posted June 17th, 2014 03:00

    Can you post the exact output ?

  • 573

    0

    Posted June 17th, 2014 03:00

    NAS Code upgrade fails with the following error : 

    7:19 [ 75/82 ]  configure snmpd hidden user                          1  minute
    Start at: Tue Aug 21 07:19:59 2012

    failed to configure snmp user: server_2 :
    Error 5: server_2 : Input/output errorTimed out
    server_2 :
    Error 5: server_2 : Input/output errorTimed out
    Run "$NAS_DB/sbin/configure_snmp_user ALL" command after installation/upgrade.
    Complete at: Tue Aug 21 07:20:56 2012


    Investigating the problem showing SNMP is not working on any Data Mover:

    $ server_snmpd server_2 -modify -location EMC-TEST
    server_2 :
    Error 13690601492: server_2 : Input/output error Internal MAC Socket Error 10: Connection timeout:

    cmd_log.err indications:

    2012-08-21 07:36:23.140 server_2:201:16552:E: .server_snmpd server_2 -modify -location EMC-TEST: Internal MAC Socket Error 10: Connection timeout:
    2012-08-21 07:52:20.236 server_2:201:30532:E: /nas/bin/.server_snmpd server_2 -reconfignetstat: Internal MAC Socket Error 10: Connection timeout:
    2012-08-21 07:52:41.893 server_2:201:31030:E: /nas/bin/.server_snmpd server_2 -migrate: Internal MAC Socket Error 10: Connection timeout:

    Product : Celerra
    EMC SW: NAS Code 6.0.x

    Product: VNX

    EMC SW: VNX Operating Environment (OE) for File 7.0.x
    The problem is related to the fact that the snmpd daemon on the Data Mover is not started.

    Confirm the snmpd daemon is appearing on the netd file on nasdb:

    $ grep snmp /nas/server/slot_2/netd
    snmpd

    Schedule a Data Mover failover and failback to reload the daemon or contact EMC Support for further assistance.

    The upgrade would continue and eventually finish so this does not stop an upgrade.
    Fix: Issue can be resolved by manually restarting the snmpd daemon on the Data Mover:

    $ .server_config server_2 -v "snmpd"
    server_2 : commands processed: 1
    command(s) succeeded
    output is complete

    1345560905: UFS:11: Staging new blockno: block-13789 ftnsize-3 sizewritten-3 aiocnt-1
    1345560905: UFS: 7: inc ino blk cache count: nInoAllocs 7: inoBlk 0x011660fab0
    1345560905: UFS:11: Staging new blockno: block-13792 ftnsize-1 sizewritten-1 aiocnt-1
    1345560905: ADMIN: 6: Command succeeded:  snmpd

    $ server_snmpd server_2 -info
    server_2 :
    enabled   = No
    location  = here
    contact   = nasadmin
    community = public

    $ server_snmpd server_2 -service -status
    server_2 :
    SNMP Stopped

    $ server_snmpd server_2 -service -start
    server_2 :
    OK

    $ server_snmpd server_2 -service -status
    server_2 :
    SNMP Running

    $ server_snmpd server_2 -info
    server_2 :
    enabled   = Yes
    location  = here
    contact   = nasadmin
    community = public

    $ server_snmpd server_2 -modify -location ACP-EMC-DC
    server_2 :
    OK

    $ server_snmpd server_2 -info
    server_2 :
    enabled   = Yes
    location  = ACP-EMC-DC
    contact   = nasadmin
    community = public

  • Rainer_EMC

    6 Operator

    •

    8645 Posts

    573

    0

    Posted June 17th, 2014 08:00

    I guess its an account on the data mover that server_netstat uses

  • Priam2

    11 Posts

    573

    0

    Posted June 17th, 2014 08:00

    I can't, it was just a item that scrolled by along with the progress bar while doing an upgrade of a Celerra NS-120 using Unisphere Service Manager. Just wondering what purpose it serves, and why it's 'hidden'.

    Thanks!

  • Priam2

    11 Posts

    573

    0

    Posted June 17th, 2014 08:00

    That script "/nas/sbin/configure_snmp_user" doesn't give me any clues to what it actually does. I'm primarily concerned about the security implications. We're under some federal requirements regarding 'service' accounts, I think this may fall into that category.

  • Rainer_EMC

    6 Operator

    •

    8645 Posts

    573

    0

    Posted June 17th, 2014 09:00

    That is not an account that can be used to access data – just for snmp info