UNSOLVED

NachoAmoeiro

updated

13 years ago

N

NachoAmoeiro

1 Message

0

1198

October 31st, 2013 05:00

Centera connection timeout


Hello,

We have one centera cluster with 4 nodes. Two of them have Access role (c001n01 and c001n02). The other day, we have a disk replacement on c001n01. During disk replacement, after the node become online it wasn't accessible during some time (maybe it still was configuring the new disk???? ). Our application had problems accesing the cluster (in the connecting string we have both IP of access nodes), we had very longs timeouts.

To workaround the problem, I had to add a firewall rule (Linux iptables) in our application server that rejects any communication with node c001n01. With this rule, ore applicacion could acces to c001n02 without any problem.

is this normal behavior? In the SDK I can specify connection timeout, but I can only configure it after the pool is open (is not a global option).