Usage of loopback devices is strongly discouraged for production use. Either use `--storage-opt dm.thinpooldev` or use `--storage-opt dm.no_warn_on_loop_devices=true` to suppress this warning.
[22/Apr/2016 13:03:40] INFO [root:469] Check the Docker processes.
CONTAINER ID
IMAGE
COMMAND
CREATED
STATUS
PORTS
NAMES
05efa00c1f0e
emccorp/ecs-software-2.2:latest "/opt/vipr/boot/boot." Less than a second ago Up Less than a second
ecsmultinode
[22/Apr/2016 13:03:40] INFO [root:505] Backup common-object properties file
[22/Apr/2016 13:03:40] INFO [root:509] Copy common-object properties files to host
[22/Apr/2016 13:03:40] INFO [root:513] Modify Directory Table config for multi node
[22/Apr/2016 13:03:40] INFO [root:517] Copy modified files to container
[22/Apr/2016 13:03:40] INFO [root:525] Backup ssm properties file
[22/Apr/2016 13:03:40] INFO [root:529] Copy ssm properties files to host
[22/Apr/2016 13:03:40] INFO [root:533] Modify SSM config for multi node
[22/Apr/2016 13:03:40] INFO [root:537] Copy modified files to container
[22/Apr/2016 13:03:40] INFO [root:541] Adding python setuptools to container
[22/Apr/2016 13:03:40] ERROR [root:571] global name 'DockerCommandLineFlags' is not defined
Traceback (most recent call last):
File "step1_ecs_multinode_install.py", line 542, in modify_container_conf_func
Unforntunately I am much more familiar with other installations. Any ideas what to do here?
The single node installed but after setting up a bucket I cannot add that to a data CAS user as the home bucket. This one fails with an API Server error and the jcenteraverify gives an authentication failed with the created .pea file.
Your first issue is a something that's already been patched; you can fix it either by downloading the latest release, executing "git pull" from your repository directory (if you obtained ECSCE via "git clone"), or by adding the line "DockerCommandLineFlags=[]" below the two lines beginning with "logging" and "logger" near the top of the script (if you just want a quick fix).
The authentication phase may take quite some time to come up, but if it's consistent, one of the first things to try (as listed here) is to edit your firewall settings (or remove your firewall entirely if you feel so inclined).
I'm not entirely sure about the CAS/.pea issue at the moment, but I get the feeling that it may similarly be related to your port settings - is 3218 open on both UDP and TCP? If not, you may need to add those (e.g. "firewall-cmd --permanent --add-port=3218/udp") to authenticate properly against CAS.
Honestly not sure what Calo is seeing if his environment is working fine with single-node but failing authentication on multi-node for the same host; there shouldn't be additional setup necessary by comparison. Other developers with possible insight would be welcomed here.
Aaron_Peterson
1 Rookie
•
26 Posts
1986
0
Posted April 22nd, 2016 09:00
Your first issue is a something that's already been patched; you can fix it either by downloading the latest release, executing "git pull" from your repository directory (if you obtained ECSCE via "git clone"), or by adding the line "DockerCommandLineFlags=[]" below the two lines beginning with "logging" and "logger" near the top of the script (if you just want a quick fix).
The authentication phase may take quite some time to come up, but if it's consistent, one of the first things to try (as listed here) is to edit your firewall settings (or remove your firewall entirely if you feel so inclined).
I'm not entirely sure about the CAS/.pea issue at the moment, but I get the feeling that it may similarly be related to your port settings - is 3218 open on both UDP and TCP? If not, you may need to add those (e.g. "firewall-cmd --permanent --add-port=3218/udp") to authenticate properly against CAS.