UNSOLVED

ALEX_SERYOGIN

updated

14 years ago

0

1362

August 26th, 2012 22:00

backup recovery error

Hello, when you restore a file backup Linux, I get the error "No index was found. You have not backed up any files from the source machine, or you need to connect to the server as the supervisor." Although the backup can be removed without problems.

  • CarlosRojas

    1 Rookie

    •

    1693 Posts

    306

    0

    Posted August 27th, 2012 01:00

    Hello Alex,

    Could you run the restore from the client, from command line adding some debug options so we can have more information?

    Thank you.

    Carlos.

  • ble1

    6 Operator

    •

    14354 Posts

    •

    56186 Points

    306

    0

    Posted September 2nd, 2012 23:00

    ALEX.SERYOGIN wrote:

    Hello, when you restore a file backup Linux, I get the error "No index was found. You have not backed up any files from the source machine, or you need to connect to the server as the supervisor." Although the backup can be removed without problems.

    This means either:

    a) you are running restore with user who does not have permission to browse the index or

    b) index has been saved under different client name

    c) rather unlikely, you may have run backup which does not save index (eg. wrong pool)

    d) again unlikely, your index is expired and since then no backup run

  • Panwar

    79 Posts

    306

    0

    Posted September 4th, 2012 22:00

    Hi Alex,

    If the Index are expired. Please follow the below steps and try to rebuild the index for the particular client.

    1)Take ssid of the saveset to be recoverd
      Run the below command.
       mminfo -avot -q ssid= -r name,"savetime(20)",nsavetime,ssbrowse,ssretent,ssflags,sumflags


    2) Second the mminfo command to get the index saveset details. 

      

        mminfo -avot -q name=index:Client name -r name,ssid,ssflags,sumflags,volume, nsavetime,savetime

        Search for the particular date index backup was backed up after the saveset you are trying to recover for that client

        Make a note of the ssid and nsavetime


    3) Then Run nsrchk command to rebuild the index for particular date

       nsrck -L7 -t clientname

    Regards

    Panwar

  • 306

    0

    Posted September 4th, 2012 23:00

    Hi,

    You can verify if the indexes are prsesnt for the client, using nsrls. Run the following command to check if the indexex are present and what is the size. If possible try posting the output.

    #nsrls clientname