
UNSOLVED
Error during federated backup
Simple setup:
- two nodes (eg. phy1, phy2)
- AG with with DBs
- backups configured over vir
- clients defined:
- phy1 for fs backup and SQL backup of system DBs (MSSQL:) - this is secondary
- phy2 for fs backup and SQL backup of system DBs (MSSQL:) - this is primary
- vir for SQL backup of AG instance (MSSQL#AG)
Backup preference for AG is Secondary when available. When backup is started it fails with:
43708:(pid 6628):Start time: Wed Apr 22 00:06:13 2015
43621:(pid 6628):Computer Name: PHY2 User Name: SYSTEM
29446:(pid 6628):Local host has following SQL Server online:
37977:(pid 6628): MSSQL server : PHY2
29085:(pid 6628):Microsoft SQL Server Provider error:
38006:(pid 6628):Login failed for user 'DOMAIN\PHY2$'..
66212:(pid 6628):Cannot login to SQL Server PHY1.
29085:(pid 6628):Microsoft SQL Server Provider error:
38006:(pid 6628):Conversion failed when converting from a character string to uniqueidentifier..
43709:(pid 6628):Stop time: Wed Apr 22 00:06:19 2015
It seems to suggest that access to secondary replica over (from) first node is not authorized (never seen this DOMAIN\HOST$ user syntax before), but I'm also a bit puzzled by MS error about conversion failed... Anyone seen this before and perhaps any hint where to look next? Our SQL admin was away today so could not chat with him so if anyone has hints - feel free This is SQL2012 using NMSAP 8.2SP1.
Responses (0)
Solutions (0)
