savefs generates error "No 'NSR schedule' resource named"
Greetings,
I've noticed that all the clients on one of our 2 Legato servers when I use the command "savefs -s -pv" it always generates the errors "No 'NSR schedule' resource named...". One for each schedule used. All the schedules do exist and it doesn't affect the backups, they work. Just wondering what's causing this. The clients backed up by the other server doesn't have this problem.
Legato: v7.2.2
Servers: RedHat Linux 3.6
Clients: RedHat Linux & Tru64 Unix
Example)
csubss2:/> /usr/opt/networker/bin/savefs -s solegato2 -pv
No 'NSR schedule' resource named Full Aft Midnight
No 'NSR schedule' resource named Lvl 1 Aft Midnight
No 'NSR schedule' resource named Full Aft Midnight
No 'NSR schedule' resource named Full Bef Midnight
type: NSR client description;
pools supported: Yes;
migration supported: Yes;
browse time supported: Yes;
multiple balanced streams supported: Yes;
.
.
.
Never saw that before, but what happens if you instead "namenamenamename" you use "name_name_name_name"? I would need to blame something I would start from spaces first
You can give it a try and see if that changes anything - if yes then I guess we know what could be the issue.
If you do something like grep "pattern" */* from pwd above you will find it. But I would be surprised if that would be problem as usually this is all set correctly. What if you restart daemons? I use these versions and platform, but I didn't see this before.
Do you get this when you get server initiated backup? Stae of things is that usually enduser should never run savefs alone. When it runs as initiated by backup server you get some additional switches involved like -c and group name and etc. Here is an example:
So, in your case I would try something "savefs -vpn" first. If you wish to go against server, then add more switches, but have in mind that savefs might giving you this as it misses some information that usually has.
OK, I tried 'savefs -vpn' on both client and server. The error doesn't occur on the server. A network issue? The server in question is on the other side of the firewall so I set up a client for a system that is on the same side of the firewall as the Legato server and it gets the error.
Could be. Try usual things that NetWorker likes as nslookup and rpcinfo and see if they work as expected (even I would be surprised if DNS was used in DMZ).
vsemaska
194 Posts
382
0
Posted September 22nd, 2006 06:00
Tried it and that one shows up as well so spaces is not the issue. Maybe a file permissions issue? Where are the schedules kept?
Thanks,
Vic