Announcement Banner
UNSOLVED

WDITLS

updated

9 years ago

W

WDITLS

14 Posts

0

3178

May 6th, 2017 06:00

PowerVault 3260i continual preferred path errors

Hi our PV 3260i has continual preferred path errors.

I can fix it by redistributing but within less than an hour the error is back. I'd like to get to the bottom of this long standing problem if anyone could assist please?

Thanks!

  • DELL-Josh Cr

    Community Manager

    •

    9741 Posts

    •

    44395 Points

    588

    0

    Posted May 8th, 2017 10:00

    Hi,

    Are the servers connected directly to the MD or is there a switch in between? Losing the preferred path means that there is a loss of communication somewhere. It could be cabling a switch, updating firmware on both sides might also help. 

  • DELL-Josh Cr

    Community Manager

    •

    9741 Posts

    •

    44395 Points

    588

    0

    Posted May 8th, 2017 11:00

    Does it happen to both controllers? When it happens are you able to ping the iSCSI host ports?

    PING the iSCSI Host Ports.

    1. Ping the iSCSI HOST
    2. Open a command line.
    3. Move to the directory containing SMI.exe (The default location is C:\Program Files\Dell|MD Storage Manager\client).
    4. At the command line type ping [xxx.xxx.xxx.xxx] and press the key, where [xxx.xxx.xxx.xxx] is the IP address
      of one of the iSCSI controllers on the host. An unsuccessful ping returns the IP address.

    Repeat step 3 with the address of the second iSCSI controller.

  • WDITLS

    14 Posts

    588

    0

    Posted May 8th, 2017 11:00

    It's directly connected and the cabling has been replaced with brand new Cat 6 cabling and the SAN and hosts have all been firmware updated to the latest version but it still continues and occurs multiple times per day even when there is no load/throughput to speak of.

  • WDITLS

    14 Posts

    588

    0

    Posted May 8th, 2017 11:00

    Two PowerEdge R720 servers

  • DELL-Josh Cr

    Community Manager

    •

    9741 Posts

    •

    44395 Points

    588

    0

    Posted May 8th, 2017 11:00

    What model server is connected to it? 

  • DELL-Josh Cr

    Community Manager

    •

    9741 Posts

    •

    44395 Points

    587

    0

    Posted May 8th, 2017 12:00

    Once it switches paths you can see if it can still ping the original path.

  • WDITLS

    14 Posts

    587

    0

    Posted May 8th, 2017 12:00

    Wouldn't I have to do this at the exact moment the preferred path error occurs? That's going to be very difficult.

  • DELL-Josh Cr

    Community Manager

    •

    9741 Posts

    •

    44395 Points

    458

    0

    Posted May 8th, 2017 12:00

    How are the servers directly connected? Is it two ports per server? Is there a reason why you are not using a switch? Can you provide a diagram of the connection? Is each host in its own subnet? Page 18 of the config guide. http://downloads.dell.com/manuals/common/powervault-md3200i_deployment%20guide_en-us.pdf

  • WDITLS

    14 Posts

    587

    0

    Posted May 8th, 2017 12:00

    Well given I can immediately redistribute the disks -  I'd say a ping would work!

    Both hosts are connected to each controller and both controllers error - it's not consistently controller 0 or 1 for example.

  • WDITLS

    14 Posts

    587

    0

    Posted May 8th, 2017 12:00

    Ok, confirmed I've just had an alert for the preferred path error and both hosts can ping both controllers no issues.