Notification à l’attention des clients FluidFS : comment le service de récupération libère de l’espace sur un pool NAS

Résumé: Cette notification client explique comment le service de récupération libère de l’espace sur un pool NAS.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Lorsqu’un snapshot est supprimé, il est analysé pour libérer les blocs qu’il possédait en exclusivité. Ce processus, c’est-à-dire reclaimer, s’exécute en arrière-plan.

Plus le snapshot est volumineux, plus l’opération prend du temps. Après l’exécution de l' reclaimer Le processus terminé, la totalité de l’espace libéré devient disponible pour le volume. 

Il doit s’exécuter avant que les blocs ne puissent être démappés à l’aide de SCSI unmap (s’il est activé) dans les volumes SAN back-end.

La commande reclaimer Le processus se met en file d’attente pour s’exécuter lorsque des données sont supprimées sur le pool NAS, notamment des données supprimées des partages, des volumes NAS et des suppressions de snapshots.

Cause

Limites et problèmes connus

  • La commande reclaimer Le service ne peut pas être exécuté manuellement ou arrêté pendant une période prolongée. Une fois qu’il a commencé, il doit terminer sa file d’attente avant que de l’espace ne soit libéré dans le pool NAS. 
  • La récupération des snapshots est gourmande en ressources. Si un grand nombre d’activités de récupération se produisent simultanément, cela peut entraîner des problèmes de performances sur l’ensemble du cluster.  
    • Les opérations de récupération gourmandes en ressources peuvent avoir un impact tel sur les performances qu’elles peuvent affecter l’accès client au cluster.
  • Il existe une limite de création et d’expiration de snapshots qui varie en fonction de la charge globale du système en fonction de l’appliance. Cela peut avoir un impact direct sur le fonctionnement du récupérateur et du système.
    • Tandis que reclaimer a été améliorée dans le firmware FluidFS v6 Pour les suppressions de snapshots, il est possible qu’un service de récupération surchargé affecte l’accès client. Ces événements sont signalés comme suit : "clients may encounter a long period of partial data access"

Vérifiez si les problèmes de performances se produisent au moment de l’expiration de certains snapshots.

Il existe plusieurs types de snapshots :

  • Snapshots manuels : snapshots qui expirent lorsque l’administrateur les supprime ou en fonction du délai d’expiration défini par l’administrateur. 
  • Snapshots planifiés : snapshots qui expirent en fonction des détails du planning. Les noms sont basés sur le nom de la planification.
  •  Snapshots NDMP (Network Data Management Protocol) : snapshots qui expirent une fois la sauvegarde NDMP terminée. Les noms commencent par ndmp.
  • Snapshots de réplication : snapshots qui expirent une fois la réplication suivante terminée avec succès. (Lors d’une réplication, il existe deux snapshots, le snapshot précédent et le snapshot actuel.) Le nom des snapshots de réplication commence par rep.

Résolution

    Échelonnement des tâches de snapshots (snapshots standard, réplication, NDMP)

    Si de nombreux snapshots expirent simultanément, cela peut entraîner des problèmes de performance. 

    Des snapshots moins nombreux, mais plus volumineux qui expirent simultanément peuvent également causer des problèmes de performance.

    Il est recommandé d’échelonner les snapshots horaires dans le temps (par paliers de 10 minutes) et d’échelonner les snapshots quotidiens sur la journée (expirant de préférence la nuit). Les snapshots hebdomadaires doivent de préférence expirer le week-end.

    Produits concernés

    FS Series, Dell Compellent FS8600
    Propriétés de l’article
    Numéro d’article: 000178040
    Type d’article: Solution
    Dernière modification: 06 May 2026
    Version:  8
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