Notificación para el cliente de FluidFS: cómo el servicio de recuperador libera espacio en un pool de NAS
Resumen: En esta notificación para el cliente, se explica cómo el servicio de recuperador libera espacio en un pool de NAS.
Síntomas
Cuando se elimina una instantánea, se escanea para liberar los bloques de su propiedad exclusiva. Este proceso, también conocido como reclaimer, se ejecuta en segundo plano.
Cuanto más grande sea la instantánea, más tardará esta operación. Después de que el reclaimer El proceso finalizó, todo el espacio liberado queda disponible para el volumen.
Debe ejecutarse antes de que se puedan anular la asignación de bloques mediante SCSI unmap (si está habilitado) en los volúmenes SAN de back-end.
La variable reclaimer Las líneas de espera de procesos se ejecutan cuando se eliminan datos en el pool NAS, incluidos los datos eliminados de recursos compartidos, volúmenes NAS y eliminaciones de instantáneas.
Causa
Limitaciones y problemas conocidos
- La variable
reclaimerEl servicio no se puede ejecutar manualmente ni detener durante un período prolongado. Una vez que comienza, debe terminar su cola antes de que se libere espacio en el pool NAS. - La recuperación de instantáneas requiere un uso intensivo de recursos. Si hay mucha actividad de recuperación de forma simultánea, esto podría causar problemas de rendimiento en todo el clúster.
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- Las operaciones de recuperación con uso intensivo de recursos pueden llegar a perjudicar demasiado el rendimiento, lo que puede afectar el acceso de cliente al clúster.
- Hay un límite de creación y vencimiento de instantáneas que varía según el dispositivo en función de la carga general del sistema. Esto podría afectar directamente la funcionalidad del recuperador y del sistema.
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- Si bien
reclaimerse mejoró en el firmware v6 de FluidFS para las eliminaciones de instantáneas, es posible que un servicio de recuperación de problemas afecte el acceso de los clientes. Estos eventos se informan como:"clients may encounter a long period of partial data access"
- Si bien
Compruebe si los problemas de rendimiento se producen en torno al vencimiento de algunas instantáneas.
Existen varios tipos de instantáneas:
- Instantáneas manuales: instantáneas que vencen cuando el administrador las elimina o según el tiempo de vencimiento establecido por el administrador.
- Instantáneas programadas: instantáneas que vencen según los detalles del programa. Los nombres se basan en el nombre del programa.
- Instantáneas de Network Data Management Protocol (NDMP): instantáneas que vencen cuando se completa el respaldo de tipo NDMP. Los nombres comienzan con ndmp.
- Instantáneas de replicación: instantáneas que vencen después de que se completa correctamente la siguiente replicación. (Durante una replicación, hay dos instantáneas, la instantánea anterior y la instantánea actual). Los nombres de las instantáneas de replicación comienzan con rep.
Resolución
Tareas de instantáneas escalonadas (instantáneas estándar, replicación y NDMP)
Si muchas instantáneas vencen simultáneamente, esto podría causar problemas de rendimiento.
Menos instantáneas que vencen simultáneamente, pero de mayor tamaño, también pueden causar problemas de rendimiento.
Se recomienda escalonar las instantáneas por hora en el tiempo (pasos de 10 minutos) y escalonar las instantáneas diarias durante el día (preferentemente, que venzan por la noche). Es preferible que las instantáneas semanales venzan los fines de semana.