Dell Unity/VNX: Broadcom (VMware) cannot see LUNs correctly if they are in multiple Storage Groups and the HLU does not match (User Correctable)

Summary: ESXi Servers can get SCSI reservation conflicts if the Array LUNs are in multiple Storage Groups and the Host LUN ID (HLU) is inconsistent.

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Symptoms

This is a typical procedure for clustering multiple physical hosts to the same LUN or LUNs, for example, ESXi.

How to be sure that a LUN's Device ID or HLU Number is the same in multiple Storage Groups, or across hosts.
Troubleshooting LUNs that are present in more than one Storage Group.
Sharing LUNs between physical ESXi servers.

A LUN that is in multiple Storage Groups does not have matching HLU entries.
Some Broadcom (VMware) servers can see the LUNs, but others may report SCSI reservation conflicts.

LUN device numbers in the host CxTxDx value are not the same as other hosts, which are members of different Storage Groups.

Multiple hosts in the same Storage Group all have access to the same LUNs. All hosts must have the same Host LUN designation and each host must have the same preferred path (the Default SP Owner) to each LUN.

Cause

It is possible to add a LUN to multiple Storage Groups for ESXi, so that some, but not necessarily all, of the LUNs could be shared. If all LUNs are shared, then it may be simpler to have a large storage group for all the clustered hosts and LUNs. When adding LUNs to multiple Storage Groups, the best practice is to be sure that the same HLU number is always used for the same Array LUN.

Not matching the HLU correctly can result in ESXi misinterpreting the mismatched HLU as another copy of the LUN, such as a Snap or Clone. This in turn could lead to SCSI reservation conflicts and data unavailability.

There are exceptions, such as Storage Groups for backup servers or RecoverPoint.
The LUNs in these groups are not mounted directly on ESXi and would not cause SCSI reservation issues.
Therefore, any backup server or RecoverPoint Storage Groups should be ignored when looking for HLU conflicts.

Resolution

When LUNs are added into a Storage Group, the Host ID field is blank. This field dictates the HLU of that LUN, which is the Host Device ID, as seen by any hosts in that group. If the Host ID field is not edited before pressing apply, the HLU number defaults to the next available value. Clicking the host ID space presents a drop-down box that can be used to select the required HLU.

To correct mismatched Host ID, shut down any servers that use the Storage Group LUN that is being edited. Optionally unmount the storage, because removing a LUN from the group makes it unavailable. If a LUN is in multiple Storage Groups with mismatched HLUs, this can be fixed. Remove the LUN from the group, and adding it back with the correct number. Make each group's HLU match, assuming that this HLU is available. It may be necessary to take more than one of the affected Storage Groups offline. If one of the Storage Groups is the HLU wanted, the others must be changed to match it.

Once all the necessary changes are made to the Storage Groups, the hosts must be rebooted, or rescanned. The LUNs should then be detected on their new IDs.

For more information about this issue, see the following articles from Broadcom (VMware):

Additional Information

Warning! If a LUN is placed in more than one Storage Group, all servers in those Storage Groups must be in a cluster configuration. This prevents data corruption on the LUNs, which would happen if more than one server is writing to a LUN without cluster control.

Affected Products

Dell EMC Unity, VNX/VNXe
Article Properties
Article Number: 000030039
Article Type: Solution
Last Modified: 27 Feb 2025
Version:  5
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