Avamar Client: VSS exception code 0x80042302 or 0x80042301 returned when doing a File System or VSS backup

Summary: Avamar Client: VSS exception code 0x80042302 or 0x80042301 returned when doing a File System or VSS backup

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



When doing a Windows File System or Windows VSS backup, Microsoft VSS returns on of the following errors:

In Avamar 7.0

avtar Warning <6697>: VSS exception code 0x80042302 thrown creating object - 'code 0x80042302: No error description string'
avtar Info <10662>: Unable to create volume snapshot; backup proceeding with original (non-snapshot) volume content.  Some file content may not be backed up.

avvss Error <12077>: VSS returned an error message exiting HR = 0x80042302


In Avamar 7.1 or newer

avtar Warning <19005>: Could not initalize the VSS Service - verify that the bitness of the OS and the applications match
avtar Warning <6697>: VSS exception code 0x80042301 thrown creating object - 'code 0x80042301: No error description string'
avtar Warning <10662>: Unable to create volume snapshot; backup proceeding with original (non-snapshot) volume content.  Some file content may not be backed up.

avvss Warning <19005>: Could not initalize the VSS Service - verify that the bitness of the OS and the applications match
avvss Error <12077>: VSS returned an error message exiting HR = 0x80042301


As stated in the avtar messages, the Windows File System will continue, but open file errors may occur.  This will cause the backup to complete with exceptions.

The Windows VSS backup is a warning instead of an error and will not continue with the backup.  This will result in the backup failing.

Cause

The "Volume Shadow Copy" service is disabled on the Windows machine.

Resolution

Run the following commands from a command prompt to verify the issue outside of Avamar:

diskshadow

This will open a separate diskshadow prompt.  From there issue the following commands.  Each on it's own line followed by Enter:

reset
set verbose on
set option differential
set context volatile nowriters
add volume c:


This should return the following error:

COM call "(*vssObject)->InitializeForBackup" failed.

The last operation failed.
    - Returned HRESULT: 80042302
    - Error text: VSS_E_UNEXPECTED


Open the Application log in Event Viewer.  The following errors will be found:

Log Name:      Application
Source:        VSS
Event ID:      13
Level:         Error
Description:
Volume Shadow Copy Service information: The COM Server with CLSID {e579ab5f-1cc4-44b4-bed9-de0991ff0623} and name IVssCoordinatorEx2 cannot be started. [0x80070422, The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. 

Operation:
   Instantiating VSS server
   

Log Name:      Application
Source:        VSS
Event ID:      8193
Level:         Error
Description:
Volume Shadow Copy Service error: Unexpected error calling routine CoCreateInstance.  hr = 0x80070422, The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

Operation:
   Instantiating VSS server


These errors will have a time stamp that matches the time stamp of the warnings or errors in the Avamar logs.  This errors indicate that the "Volume Shadow Copy" service is disabled.  This service is required for VSS snapshots to occur.

Open Services and set the "Volume Shadow Copy" service to "manual".  It does not need to be set to "automatic", nor does it need to be started.  It will be started whenever it is called by another process such as avtar or avvss.

Affected Products

Avamar Client

Products

Avamar Client, Avamar Client for Windows
Article Properties
Article Number: 000059060
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  4
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