AppSync: Ondersteuning voor Oracle 18.x en 19.x

Samenvatting: AppSync Oracle-support.

Dit artikel is van toepassing op Dit artikel is niet van toepassing op Dit artikel is niet gebonden aan een specifiek product. Niet alle productversies worden in dit artikel vermeld.

Symptomen

De gerepliceerde Oracle-versie was: 18,5, 18,6, 18,7, 18,8, 18,9, 19,4, 19,5 of 19,6.

AppSync biedt geen bescherming voor Oracle-versies 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5 of 19.6.

AppSync event log:
 
ServicePlanName: PROD-ABCD,ApplicationType:oracle
Resource involved at discovery phase are:
Production host Name PROD Version:Red Hat Enterprise Linux 7.7
OracleDatabase : ABCD , RAC : true , ASM : true
OracleInstance : ABCD2 , Versie : 19.6.0.0.0
 
Applicatiedetectie, er is een fout opgetreden tijdens de uitvoering van het serviceplan PROD-ABCD
Application Discovery, er zijn geen datasets die in aanmerking komen om te worden gekopieerd in het PROD-ABCD-serviceplan.
Toepassingsdetectie, toepassingsdetectiefase voor ABCD voltooid met fouten
Toepassingsdetectie, Tijdens detectie heeft AppSync gedetecteerd dat de volgende database(s) offline waren: ABCD. Als gevolg hiervan zijn ze niet beschikbaar voor bescherming.

AppSync Server-logboek:
 
02-20-2020 15:50:18.954 INFO ->>> String response: <ir_message ir_requestId="00000" ir_sessionId="00000" ir_status="0" ir_type="ArchwayRequest" master_id="0" phaseName="" pollMode="SYNC" taskId="0" timeToWait="0"><operation<>agent>Oracle</agent><command>getDatabaseInstance</command><parameters<>parameter><paramName>databaseId</paramName paramValue><>2673940419</paramValue<>/parameter>
<parameter<>paramName>databaseName</paramName<>paramValue>ABCD</paramValue<>/parameter<>parameter<>paramName>dbRole</paramName<>paramValue>PRIMARY</paramValue></parameter<>/parameters<>result return="0"/<>responses response><><![ CDATA[<instances><instance><oracleSid>ABCD2</oracleSid><oracleHome>/opt/oracle/db/dbhome/19.3.0</oracleHome><version>19.6.0.0.0</version><databaseName>ABCD</databaseName><
databaseId>ABCD:123456789:ABCD</databaseId><online>true</online></instance<>/instances>]]></response></responses></operation><version>1.0</version></ir_message>

Oorzaak

AppSync 3.9.0.0 biedt geen ondersteuning voor Oracle versies 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5 of 19.6.
AppSync 4.0.0.0 biedt geen ondersteuning voor Oracle versies 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5 of 19.6.

Oplossing

AppSync 3.9.0.0 vereist hotfix AppSync-patch-3.9.0.0_1278_R2 ter ondersteuning van Oracle versies 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5 of 19.6.

AppSync 4.0.0.0 vereist hotfix AppSync-patch-4.0.0.0_1553_R1 ter ondersteuning van Oracle versies 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5 of 19.6.

Let op dit artikel bij het inbellen van een serviceaanvraag om de hotfix te verkrijgen. Installeer de patch op de AppSync Server en push de Agent naar alle getroffen clients.

De AppSync-hotfix is van toepassing op de volgende onderdelen:
  • AppSync Server
  •  AppSync hostplug-in (AppSync hostplugin_linux en AppSync hostplugin_aix)
Opmerking: De eerste uitvoering van het serviceplan nadat de hotfix is toegepast, kan mislukken tijdens het detecteren van de applicatie.

Als de detectie mislukt voor AppSync 3.9:
  1. Ga naar het scherm AppSync > Settings > Servers, selecteer de server en voer Rediscover uit. 
  2. Ga naar het scherm AppSync > Copy Management > Oracle.
  3. Klik op de vervolgkeuzelijst naast Databases ontdekken. 
  4. Selecteer op Server en selecteer de host.
  5. Voer het serviceplan opnieuw uit.
Als de detectie mislukt voor AppSync 4.0:
  1. Ga naar het scherm AppSync > Settings > Servers, selecteer de server en voer Rediscover uit. 
  2. Ga naar het scherm AppSync > Copy Management > Copies Oracle > .
  3. Ga naar beneden voor de optie MEER en selecteer Databases ontdekken. 
  4. Markeer de server en selecteer "OK".
  5. Voer het serviceplan opnieuw uit.

Extra informatie

Oracle 19.4, 19.5 en 19.6 vereisen een Oracle-fix om een herstelprobleem op te lossen:

 
Het herstelprobleem is te wijten aan een Oracle-bug die is opgelost in de 19.3.0.0.0-release, maar later opnieuw is geïntroduceerd in de 19.4.0.0.0-release van het product.

Neem contact op met Oracle Support over het volgende basisbugnummer dat moet worden gebruikt voor het verkrijgen van patches om het probleem op te lossen op basis van het besturingssysteemplatform dat momenteel in gebruik is:

Bug 30528704: 19C RMAN DATABASE HERSTELLEN DOOR REDO LOG TE GEBRUIKEN IN PLAATS VAN ARCHIVELOG NA HET TOEPASSEN VAN OCT DATABASE RU

Raadpleeg de volgende artikelen voor meer informatie over dit Oracle-herstelprobleem:
 
Referentie: AppSync specifiek KB-artikel (167093)
Dell EMC primair artikel KB-artikel 167419: Oracle 19.6 databaseherstel mislukt door interne ORA-600-fout.

Getroffen producten

AppSync

Producten

AppSync
Artikeleigenschappen
Artikelnummer: 000170879
Artikeltype: Solution
Laatst aangepast: 05 mei 2026
Versie:  6
Vind antwoorden op uw vragen via andere Dell gebruikers
Support Services
Controleer of uw apparaat wordt gedekt door Support Services.