Unisphere for PowerMax: Mainframe configured array posts capacity alerts for an FBA SRP
Summary: The array which is configured for Count Key Data (CKD) Storage Resource Pool (SRP) posts alerts for a Flash Block Architecture (FBA) SRP. The FBA side of the SRP is not used by the customer. It is only used by the array for eMGMT, therefore there is no reason for the alerts. ...
Symptoms
In this instance, everything is running CKD. However, for the eMGMT instance, there is an FBA section of SRP_1.
The Unisphere for PowerMax version is 9.2.3.4.
On the FBA side of the pool, there are alerts that the FBA Effective used Capacity has reached 92% while the CKD side is at 59%.
According to the Unisphere and Solutions Enabler outputs, the FBA side is at 92%, but the FBA side is preallocated for eMGMT and has no other use. This means that there are no devices or space to free up. Since this array is for CKD use, the alerts should go away.
We acknowledge and delete the alerts from Unisphere and refresh the connection to ensure that there are no others. The issue still persisted in the array dashboard.
Because of the capacity usage for the FBA side, the Unisphere health score for the array was at 80% instead of 100%. This was also shown in CloudIQ.
This was seen on seven different mainframe arrays, all with the same capacity alert.
Cause
This is due to the default alert setting for Effective used Capacity, which has a critical threshold of 80%. Once the critical threshold is exceeded the health score is affected.
Resolution
To resolve this, make a custom Threshold for the FBA emulation that has the Critical and Fatal levels higher than current utilization levels. Make sure that the FBA Capacity alerts have been acknowledged and deleted from the Alerts page before following the below procedure.
Procedure
1. Select "Gear" to open the Settings panel.
2. Select Alerts > System Threshold and Alerts.
3. Create a Custom threshold for the FBA portion of the SRP_1 that is higher than the current levels.
- Click "Create"
- Select the Array
- Select category of "Effective used Capacity"
- Select SRP to apply thresholds to (The FBA side of SRP_1 is named SRP_0x102 or similar).
- Set the higher custom levels.
- Click "OK".
This sets the system to look for the newer levels instead of the default ones. This should then remove the Warning from the dashboard if there are no alerts remaining in the Alerts panel.
4. Click Apply.
5. Close the Settings panel.
6. Click the Array discover function in the top right-hand panel (an arrow going in a circle) and click "OK".
7. Once the discovery operation is complete, log out and log back into Unisphere.
8. Make sure the health score now shows 100% or at least that the -20% is gone for the SRP capacity threshold.
Reference:
Dell Technologies Unisphere for PowerMax Online Help includes a detailed section to view and set the threshold alerts:
https://dl.dell.com/content/docu100278_unisphere-for-powermax-9-2-0-online-help.zip
Additional Information
If the array code level is at 5977.1131.1131 or earlier, this workaround does not apply as the SRP_0x102 will not be listed. This fix is only for PowerMaxOS 5978 level arrays.
The options to proceed for earlier code-level arrays are:
If the array is a All Flash Array (AFA) model or later: Open a service request (SR) to upgrade the array to PowerMaxOS 5978.
If the array is a VMAX3 model or lower, they cannot go to PowerMaxOS 5978:
- Work with your local Account team to add more physical space to the FBA pool to get the capacity under 80%. Doing this removes the health score issue.
- Alternatively, you can leave the alert as is. This alert does not affect the array only the health score in Unisphere.
-
- As the 5977.1131.1131 is an old code version and not close to target code levels, no fix is planned to be made for the 5977.1131 code.