PowerStore: TLS Encryption error encountered when trying to add or modify Remote Syslog Server

Summary: The PowerStore Manager user interface (UI) reports a TLS Encryption error when you try to create or modify a Remote Syslog Server using one-way authentication (Server CA Certificate) on PowerStoreOS versions before v3.2. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When attempting to add or modify a Remote Syslog Server using a one-way authentication (Server CA) certificate, the following error may be seen on the PowerStore Manager user interface (UI):

 modify a Remote Syslog Server screen 

The UI references that either one-way or two-way authentication can be used.

Cause

A one-way authentication (Server CA) certificate is not supported on PowerStoreOS versions older than version 3.2.

Although it is referenced in the UI that both one-way or two-way authentication can be used, only two-way authentication (Mutual Authentication Certificate) is supported in PowerStoreOS releases older than v3.2.x.

Resolution

Both one-way authentication (Server CA certificate) and two-way authentication (Mutual Authentication Certificate) are supported from PowerStoreOS version 3.2 onward.

Affected Products

PowerStore 1000X, PowerStore 1000T, PowerStore 1200T, PowerStore 3000X, PowerStore 3000T, PowerStore 3200T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 5200T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T , PowerStore 9200T ...
Article Properties
Article Number: 000209360
Article Type: Solution
Last Modified: 19 Jun 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.