Connectrix SANnav: SANnav Event Manager Does Not Send Email Notifications for Some MAPS Events

Summary: Since SANnav 2.2.0, only selected MAPS events are processed.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Environment:
SANnav versions 2.2.0 and later

Issue:
The switch generated some MAPS events, but not all of them are showing up on the "Events" page of the SANnav user interface. There are no email notifications from the SANnav for those events.

Cause

There is a design change in SANnav versions 2.2.0 and later to avoid duplicate MAPS events listed on the "Events" and "Violations" pages.

All MAPS events are displayed on the "Violations" page, but only the below listed MAPS events are displayed on both the "Events" and the "Violations" pages.
 
 
MAPS-1003 MAPS-1018 MAPS-1021 MAPS-1113 MAPS-1130
MAPS-1210 MAPS-2140 MAPS-2141 MAPS-2142 MAPS-2143
MAPS-2148 MAPS-2149 MAPS-2150 MAPS-2151 MAPS-2180
MAPS-2181 MAPS-2182 MAPS-2412 MAPS-2413 MAPS-2414
MAPS-2415 MAPS-2432 MAPS-2433 MAPS-2434 MAPS-2435

Since the SANnav event manager only processes messages of the "Events" page, there are no email notifications for other events which are not in the list.

Resolution

Use the user email notifications option instead of the event manager. Here is an example of a rule to send notifications based on severity.
 
User Preferences
Figure 1: User Preferences

Edit Email Notifications
Figure 2: Edit Email Notifications
 
Rules Configuration
Figure 3: Rules Configuration
 
Selection of Rules
Figure 4: Selection of Rules
 
Rule Overview
Figure 5: Rule Overview
 
 
Article Properties
Article Number: 000210822
Article Type: Solution
Last Modified: 21 Jun 2023
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.