PowerStore: El cambio de topología de SAS puede provocar el reinicio del nodo

Resumen: Un cambio en la topología de SAS (como la desconexión de LCC, la desconexión de cables, la eliminación de varias unidades y más) puede provocar, en raras ocasiones, un reinicio del nodo. Este problema solo afecta a los dispositivos conectados a un gabinete SAS (también conocido como Tabasco). ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

El nodo se reinicia y se recupera automáticamente. En algunos escenarios, ambos nodos pueden reiniciarse y provocar una interrupción del servicio.

Causa

El controlador SAS tiene diferentes procesos para manejar la extracción de una sola unidad en lugar de la extracción de varias unidades (extracción masiva). Cuando se maneja la extracción masiva (como un problema de LCC/cable), el controlador debe anular todas las I/O para cada unidad. Existe un problema de software en el que, durante el proceso de limpieza, hay una condición de carrera con otro proceso que intenta también anular las I/O que ya no existen. Esto provoca un reinicio del nodo. Esta es una condición de carrera poco común.

Resolución

Se planea que el problema se solucione en una versión futura.
 

Solución alternativa

Comuníquese con el soporte técnico para obtener ayuda.

Productos afectados

PowerStore Expansion Enclosure
Propiedades del artículo
Número del artículo: 000210883
Tipo de artículo: Solution
Última modificación: 31 jul 2023
Versión:  5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.