NWUI: VM Revert Restore Performed in NetWorker User Interface is Stuck in Running State
Summary: Virtual Machine (VM) Revert restores performed through the NetWorker Web User Interface (NWUI) do not start. The recovery job gets stuck in the NWUI Monitoring "Recover Jobs" window and cannot be cancelled. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
A "Revert VM" Restore with "Revert VM Configuration" option is performed from the NetWorker Web User Interface (NWUI).
Figure 1: Screenshot of UI with Revert VM Configuration selected
- The VM recovery job shows as running but no recover session is started, attempting to cancel the job returns "Job is already completed."
Figure 2: Screenshot of Message that "Job is Already Completed."
- No restore session is seen in the NetWorker Management Console (NMC), or when using NetWorker Server commands below:
nsrwatch OR jobkill
- There is a message generated under
/nsr/tmpfiles in Linux orC:\Program Files\EMC NetWorker\nsr\tmpfiles in Windows as seen below:
nsrvproxy_recover_###.raw
nve:~ # nsr_render_log /nsr/tmp/nsrvproxy_recover_17012.raw
5 1 1 0 0 unknown unknown LOG unrendered 153335:nsrvproxy_recover: Virtual machine recovery failed: Cannot specify disks(-d) with Revert Vm config(-o B).
Unable to render the following message: 153335:nsrvproxy_recover: Virtual machine recovery failed: Cannot specify disks(-d) with Revert Vm config(-o B).
5 1 1 0 0 unknown unknown LOG unrendered /usr/sbin/nsrvproxy_recover -c vCenter [-s server] {-S ssid[/cloneid] | -N ssname [-t sstime]} [-m recovery-mode] [-f Folder-Moref] [-o option]... [-A Datacenter-Moref] [-C ComputeResource-Moref] [-L ClusterComputeResource-Moref] [-E Datastore-Moref] [-M VM-Moref] [-V VM-name] [-r ResourcePool-Moref] [-H Host-Moref] [-T datastore] [-e export-path] [-d disk] [-p vProxy] [-b pool] [-v] [-k]
Unable to render the following message: /usr/sbin/nsrvproxy_recover -c vCenter [-s server] {-S ssid[/cloneid] | -N ssname [-t sstime]} [-m recovery-mode] [-f Folder-Moref] [-o option]... [-A Datacenter-Moref] [-C ComputeResource-Moref] [-L ClusterComputeResource-Moref] [-E Datastore-Moref] [-M VM-Moref] [-V VM-name] [-r ResourcePool-Moref] [-H Host-Moref] [-T datastore] [-e export-path] [-d disk] [-p vProxy] [-b pool] [-v] [-k]
- The NetWorker Server and NetWorker Web User Interface Server are using the following NetWorker versions:
- 19.8.0.0 -> 19.8.0.3
- 19.9.0.0 -> 19.9.0.2
Cause
NetWorker engineering identified a code defect.
Resolution
This issue was addressed in NetWorker 19.8.0.4; however, 19.8 is End of Support Life (EOSL) as of November 11 2025. Upgrade to 19.9.0.3 or later for a code fix: https://www.dell.com/support/home/product-support/product/networker/drivers
Workaround:
Use the NetWorker Management Console (NMC) to perform VM Revert Restores. This issue is only seen in NWUI.
Additional Information
Products
NetWorker Family, NetWorker, NetWorker SeriesArticle Properties
Article Number: 000216683
Article Type: Solution
Last Modified: 04 Nov 2025
Version: 9
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.