NetWorker: Windows Client Backup pseudo_saveset - VSS errors

Summary: NetWorker Client fails for pseudo_saveset with issues on Volume Shadow Copy Service (VSS).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Backup is performed for a Windows system using the NetWorker client software.
  • The backup fails on pseudo_saveset.
  • Backup logs report Microsoft Volume Shadow Copy Service (VSS) errors. For example:
181407:save: Step (1 of 5) for PID-8600: Save has been started on the client '<client_name>'.
174412:save: Step (2 of 5) for PID-8600: Running the backup on the client '<client_name>' for the save set 'pseudo_saveset'.
174424:save: Step (3 of 5) for PID-8600: Creating the snapshot for the selected save sets.
VSS OTHER: ERROR: VSS failed to process snapshot: Unable to create the VSS snapshot.
197048:save: Unable to save the SYSTEM STATE save sets and create the snapshot: Unable to create the VSS snapshot.
NOTE: This is one example of a VSS error which may be observed. Even if this is not the exact VSS error observed, this article can still be followed.
  • Unable to create the VSS snapshot.

Cause

VSS is a Microsoft technology used by NetWorker backups. VSS issues are typically on the client regarding the operating system, or a new patch installed that impacted the VSS.

Resolution

On the client: 
  1. Open an Administrator command prompt.
  2. Stop the NetWorker client:
net stop nsrexecd /y
  1. Kill any NetWorker services which did not stop:
taskkil /F /IM nsr*
  1. Kill any NetWorker backup processes which did not stop:
taskkill /F /IM save* 
  1. Rename the C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw
  2. Remove the C:\Program Files\EMC NetWorker\nsr\tmp (any renamed /tmp directories also).
  3. Open the SERVICES (or services.msc). 
  4. Look for the VOLUME SHADOW COPY service STOP and then START for this service
  5. Start NetWorker client services again:
net start nsrexecd
  • If the issue persists, test a small file or directory to backup and exclude VSS:
  1. On the client, open an Administrator command prompt.
  2. Run the following command to test a small backup of a directory or file of your choosing:
save -vv -D5 -s <networker server name> -b <pool to backup the client to> -o VSS:*=off <directory or file to backup>
  • If the backup is successful, disable VSS in the client configuration. 
NOTE: Disabling VSS in backups should only be done as a workaround. The root cause of the VSS issues should be determined and resolved so that Windows backups can be performed with VSS enabled.
  1. To disable VSS for a particular client, open the client properties in the NetWorker Management Console (NMC).
  2. Under APPS&MODULES tab > enter Backup command:
save -o VSS:*=off
In order to root cause any VSS issue, it is recommended to engage the Microsoft administration team or Microsoft Support to review the cause of the VSS failures.

The following vssadmin commands may provide further insight on vssadmin writer status or if any VSS snapshots still reside on the system.
vssadmin list writers 

vssadmin list shadows

Affected Products

NetWorker Family
Article Properties
Article Number: 000217007
Article Type: Solution
Last Modified: 29 Nov 2023
Version:  10
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