PowerStore: RUN SYSTEM CHECK From PowerStore Manager May Not Complete with the Error "Fireman Command Failed"

Summary: RUN SYSTEM CHECK from PowerStore Manager may not complete with the error "Fireman command failed. (0xE0F010200004)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

This error is indicated with the message as shown below:
Fireman command failed. (0xE0F010200004)
Screenshot of error message "Fireman command failed"
Figure 1: Screenshot of error message "Fireman command failed"

Cause

For some PowerStore systems running operating system 3.2.x or earlier, the default time of 360 seconds for the System Check is not sufficient to complete checks. This is causing the health check job to fail.

Resolution

Workaround: 
  1. Use the following service command from the service container to check the results of the health check.
svc_health_check run
  1. If any of the checks are reported as failed, resolve the condition of the failed check.
  2. Run the following service command again to check that all tests have passed and then proceed.
svc_health_check run
NOTE: This issue is addressed in PowerStoreOS 3.5.0 by increasing the Health Check timeout value initiated by PowerStore Manager from 360 to 600 seconds.

Affected Products

PowerStore
Article Properties
Article Number: 000219217
Article Type: Solution
Last Modified: 15 Nov 2023
Version:  2
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