PowerProtect: DDBMA SQL Restore with Recovery Mode Fails with Keep_CDC Enabled
Summary: Both PowerProtect Data Manager and DDBMA stand-alone SQL restore with recovery mode fails when keep_CDC is enabled.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Even though the Restore with Recovery mode is chosen, the below error is seen in the log:
2024-04-02T05:32:16.909Z 38008 ddbmsqlrc PowerProtect Data Manager critical Option 'norecovery' conflicts with option(s) 'keep_cdc'. Remove the conflicting option and reissue the statement.
Cause
This is a known issue in PowerProtect Data Manager (up to version 19.16 as of now) and DDBMA stand-alone.
Resolution
There are two workarounds for the
Workaround 1:
Workaround 2:
CDC database. Choose one option, or the other.
Workaround 1:
Two restores must be run. 1. Select the second last backup and select norecovery (no keep_cdc option). This can be run from the UI or command line. 2. Select the last backup and select "restore with recovery" and specify keep_cdc option. Generate script and add -z option in the script and run the restore. The above restores the CDC databases. This workaround still requires manual process. We request to fix this logic so that the automated process of building recovery chain is without flaws and works for all situations without manual intervention.
Workaround 2:
1. Restore the database to a file using DDBEA 2. Restore the database through SSMS with that file 3. Check that the CDC is maintained or not Restore of database was successful and CDC was maintained too.
Affected Products
PowerProtect Data Manager, PowerProtect App Direct, PowerProtect SoftwareArticle Properties
Article Number: 000224347
Article Type: Solution
Last Modified: 27 Jun 2024
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.