PowerFlex: Troubleshooting the "IP address not in approved network" alarm in CloudLink
Summary: Adding alarmed IP to machine group and approve the newly added IP in the approved network list to clear the "IP address not in approved network" alarm.
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Symptoms
We can observe the "IP address not in approved network" alarm in the CloudLink web UI. Sometimes we can observe the same alarm even after the server connected in a CloudLink approved network.
Cause
Either the Machine is in pending state or the Machine is not on an approved network. Sometimes the Machine IP address has changed by customer.
Resolution
- The alerted Machine should be accepted by Cloudlink administrator, and it should be added in the approved network list.
- If still the alarm did not clear it could be a false entry, so CloudLink administrator must clear the alarm by restart both node of clustered CloudLink VMs one by one or Need to clear the alert from the CloudLink monitoring database with the help of the engineering team.
- Log in to the CloudLink Center web user interface by username and password
- Go to "Monitoring -> Alarms" option in the left side of the contents pane.
- Click the "Alarms" menu and you can see the list of triggered alarms.
- If you see the alarm related to "pending machine," Select the alarm by click the checkbox.
- Below you can see the selected alarm details, there you can find the details "IP address not in approved network"
- Note down the hostname and find the IP of the respective hostname by click the "Target machine" link which is present above the "details."
- And Go to the "Machines" menu which is present under "AGENTS" tab and check the respective server IP status whether it is "Pending/Connected" state.
- If the Machine is in "Pending" state, approve it by select the respective machine in the checkbox and click the "Accept" option. Find the image below for reference.
Note: If a Machine violates the policy, or if it is not on an approved network, it is placed in a 'pending' state. A machine stays in a pending state until a CloudLink administrator accepts or rejects the violation. Keys are not released to the Agent until the machine status is accepted.
- And check the server status under "Machines" menu, it should be in "Connected" state.
- And go to the "Approved network" submenu which is under the "AGENTS" menu.
- There you can find the list of approved network IPs.
- Check the noted alarmed IP whether is listed there or not. If not, add the affected alarmed server IP (Action -> Add IP to network -> Type (Select IP Address) -> enter affected IP address -> Click Add).
- The alarm will be clear automatically once the IP address will is got added in to approved networks, try to log off from the session and login to CloudLink web UI after 5 minutes and check the Alarm list.
- If the Alarm cleared, then the issue has been resolved.
Note: Sometimes in rare scenario we can see the issue that even if the Machine IPs are under the approved network list or already in Connected state, we can see the same "IP address not in approved network" alarm in CloudLink.
- In this case, we can confirm that this is will be a false alarm which is not cleared even after network has been approved. So we must clear the triggered alarm by restart both the CloudLink VM’s one after other.
- After reboot, login both the CloudLink node web UI and check the cluster sync status under (SYSTEM -> CLUSTER), It should be synchronized. And check the alarm whether it is cleared or not.
- If the Alarm cleared, then the issue has been resolved.
- If still the Alarm "IP address not in approved network" not cleared, follow the below mentioned KB to clear the alarm from the CloudLink database.
Clear the CloudLink Alarm KB: https://www.dell.com/support/kbdoc/000184857
Additional Information
About Approved networks in CloudLink:
- Approved networks are definitions within the CloudLink Center that specify which individual IP addresses, address ranges, or full subnets, are allowed for agents making key requests.
- If a NAT'd firewall exists between the CloudLink Center and the agent, the approved addresses should be the addresses as seen by the agents located behind the firewall.
- When entering the information, you can define one approved network with all the IP addresses and ranges, or you can group various IP address ranges into different approved networks.
Affected Products
CloudLinkProducts
PowerFlex rackArticle Properties
Article Number: 000227111
Article Type: Solution
Last Modified: 08 Jul 2025
Version: 2
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