Dell NativeEdge: Endpoint Metrics are Unavailable Due to High Endpoints Count

Summary: On the Endpoints > Endpoint detail > Metrics tab, metrics do not display if there are many endpoints connecting to a NativeEdge Orchestrator.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

On the Endpoints > Endpoint detail > Metrics tab, metrics fail to display.

The issue happens only if there are many endpoints connecting to a NativeEdge Orchestrator (NEO).

The UI shows no error, but it fails to load or display the metrics graphs.

Cause

NativeEdge Orchestrator uses Victoria Metrics for its gathering of metrics data. In NEO 3.1, the storage PersistentVolumeClaim (PVC) for where this data is stored (vmstorage) is sized for 50 GB.

Resolution

Workaround

Users planning to onboard over 50 endpoints in a single NativeEdge Orchestrator (NEO) should update the configuration to ensure metrics display correctly for all endpoints.


Recommended value

  • For 50-100 endpoints, change the retention period to 30 days.
  • For 100-200 endpoints, change the retention period to 15 days.
  • For 200-400 endpoints, change the retention period to 7 days.
  • For 400-800 endpoints, change the retention period to 3 days.

On the Native Edge Orchestrator, use kubectl to edit the mist-ee-vmstorage file to change the value of the retention period for Victoria Metrics. The default value is retentionPeriod=12 (12 months):

  1. Edit the mist-ee-vmstorage stateful set:
    kubectl edit statefulsets mist-ee-vmstorage -n hzp
  2. Using the editor, find the retentionPeriod parameter which is set to retentionPeriod=12, and change its value accordingly such as retentionPeriod=30d for a retention period of 30 days.
  3. Save and exit the editor.

This issue is planned to be addressed in a future release of NativeEdge.

Affected Products

NativeEdge Solutions, NativeEdge
Article Properties
Article Number: 000303312
Article Type: Solution
Last Modified: 30 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.