Dell Unity: Replication session in degraded state when destination pool is full
Summary: "Cannot update destination because destination pool is full" (User Correctable)
Symptoms
When trying to create an Asynchronous Replication session on a thick resource, Unisphere prompts an error message:
Cannot update destination because destination pool is full
You are also able to see this in Unisphere's Alerts in the UI or in EMCSystem.log in the CLI:
"[WARN] User: Replication session rep_sess_res_3_res_12_CKMXXXXXXX_CKMYYYYY can not update destination because destination pool is full." "[WARN] User: Replication session rep_sess_nas_2_nas_6_CKMXXXXXXX_CKMYYYYY can not update destination because destination pool is full."
If the error occurring is specifically "Destination Pool Out Of Space (0x840f)," refer to Article Number 000537516.
Cause
This is function as design for Asynchronous Replication on thick storage resources.
The storage resource and its snapshot each take respective space in the destination pool during the initial copy.
This is not applicable for Synchronous Replication and does not require to double capacity at the target when the initial copy is ongoing.
Resolution
The issue only occurs to thick storage resources with Asynchronous Replication environments only.
To avoid excessive space used for the initial copy, create Asynchronous Replication sessions on thin storage resources or use Synchronous Replication.
Alternatively, if the storage resources are block ones (LUNs) they can be Move as "Thin" locally in order to change its provisioning (not supported for File Systems - Article Number 000529907) (Requires a Dell Support account to view this article)
If the Asynchronous replication is already in place or intends to be created on thick storage resources, ensure that the pool on the Destination Array has enough space (at least twice the replicated resources) to prevent its pool from filling up.
To resolve already full Storage Pools on a Destination Array, expand the Storage Pool.