Dell Unity: Replication Not Syncing due to "Destination Pool Out Of Space (0x840f)"
Summary: Dell Unity: Replication Not Syncing due to "Destination Pool Out Of Space (0x840f)" (Dell Correctable)
Symptoms
The system was upgraded to Unity OE 4.X code.
Upgrading to 4.4.0.1534750794
Async File Replication is Failing to Sync.
The Unisphere Error is "can not update destination because destination pool is full."
Destination Pool however is showing free capacity.
Replication Session Output shows the Issue:
********************************************************************************************************* Session 171798693759_APM0012345678_0000_171798743954_APM0012345679_0000 ********************************************************************************************************* Name = rep_sess_res_27_res_175_APM0012345678_APM0012345679 Session type = file Synchronization type = auto RPO = 10m Resource type = File System Sync State = idle Health state = Degraded/Warning (10) Health details = "The replication session is operating in a degraded state because the storage pool on the destination system has run out of space. Expand the pool to restore normal operation." <<<<<<<<<<< Operational status = Destination Pool Out Of Space (0x840f) <<<<<<<<<<< Source status = Pool Out of Space <<<<<<<<<< Destination status = Pool Out of Space <<<<<<<<< Network status = OK Destination type = remote Destination system = RS_3 Local role = Source Source resource = res_27 Source SP-A interface = 192.168.1.1 Source SP-B interface = 192.168.1.2 Destination resource = res_175 Destination SP-A interface = 192.168.1.3 Destination SP-B interface = 192.168.1.4 Time of last sync = N/A Sync status = Sync transfer rate = N/A Sync transfer size remaining = 331786223616 (309.0G) Previous transfer rate = N/A Average transfer rate = N/A Element pairs = N/A Hourly Snapshot Retention = Hourly snapshots not replicated Daily Snapshot Retention = Daily snapshots not replicated Hourly snapshot keep for = not replicated Hourly snapshot allow auto-delete = not replicated Daily snapshot keep for = not replicated Daily snapshot allow auto-delete = not replicated
EMCSystemLogFile.log
A 09/11/19 18:13:06.114 DART_REP 106c0018 [WARN] System: Source=171798693759_APM0012345678_0000_171798743954_APM0012345679_0000(alias=rep_sess_res_27_res_175_APM0012345678_APM0012345679), starting transfer. Destination has no space available. Source is retrying. Line 3772187: A 09/11/19 18:14:00.656 Health 6077f [WARN] User: Replication session rep_sess_res_27_res_175_APM0012345678_APM0012345679 can not update destination because destination pool is full.
Cause
This problem is relevant to Unity OE Codes 4.X and above.
The problem is related to FileSystem or Snapshots that were of non-integer size.
Upgrading to 4.4.0.1534750794 exposed this issue "can not update destination because destination pool is full" on existing file systems or snaps that were of non-integer size.
Prior to the upgrade to 4.4.0.1534750794 having non-integer snaps or file systems were not an issue.
Any newly created snaps or file systems after the upgrade work properly.
It is non-integer file systems or snaps created before the upgrade that have the issue.
Resolution
Contact Dell Customer Support and quote this Dell Knowledge Base article for further assistance.
Upgrade the Unity OE to latest GA 5.0 to pick up the fix for this issue.