Jak vymazat zbytky v nástroji Dell Threat Defense nebo Dell Endpoint Security Suite Enterprise

Shrnutí: Zjistěte, jak odstranit zbylé soubory ze systémů Dell Threat Defense a Dell Endpoint Security Suite Enterprise pomocí nástroje Cylance Cleanup Tool po automatickém nebo lokálním upgradu. ...

Tento článek se vztahuje na Tento článek se nevztahuje na Tento článek není vázán na žádný konkrétní produkt. V tomto článku nejsou uvedeny všechny verze produktu.

Příznaky

Poznámka:

Dotčené produkty:

Dell Threat Defense
– sada Dell Endpoint Security Suite Enterprise


Příčina

Pokud tyto soubory zůstanou doma, může dojít k selhání operačního systému, což značí selhání softwaru CylanceDRV nebo CyPROTECTDrv.

Řešení

Tyto pozůstatky mohou být přítomny v konkrétním scénáři:

  • Verze klienta Dell Endpoint Security Suite Enterprise nebo Dell Threat Defense je upgradována z verze 154x nebo starší na verzi 156x nebo novější.
  • Pokud je agent odinstalován, mohou být po upgradu na verzi 156x nebo novější přítomny zbytkové soubory a položky.

Verze 156x zavádí přepracovaný ovladač, který nahrazuje předchozí ovladače. Pokud výše uvedený scénář vyhovuje vašemu prostředí, doporučuje se použít nástroj Cylance Cleanup Tool, který si můžete vyžádat od podpory společnosti Dell, abyste předešli problémům při přeinstalaci agenta Dell Endpoint Security Suite Enterprise.

Poznámka: Tyto kroky platí pouze pro systém Windows. Systém macOS ESSE a Threat Defense 156x nebo vyšší nepoužívají sjednocený ovladač.

Místní počítač

  1. Extrahujte CyCleanupSvc.exe a CylanceCleanupTool.bat do stejného adresáře v cílovém počítači.
  2. Spusťte CylanceCleanupTool.bat jako správce.
  3. Po dokončení čištění se vytvoří adresář Logs obsahující soubor protokolu s úlohami provedenými nástrojem.

Vzdálený počítač (platformy pro správu, například SCCM, KACE atd.)

  1. Zajistěte, aby byl CyCleanupSvc.exe distribuován do každého koncového bodu.
  2. Chcete-li provést vyčištění, spusťte následující příkaz pomocí nástroje pro správu systému, jako je Workspace ONE nebo System Center Configuration Manager společnosti Microsoft, nebo s oprávněními místního správce nebo místního počítače:
CyCleanupSvc.exe -install
  1. Po dokončení čištění se ve složce, kde se CyCleanupSvc.exe nachází, vytvoří adresář Logs obsahující soubor protokolu se seznamem úloh prováděných nástrojem. Tento soubor protokolu obsahuje data změněná během procesu čištění.
  2. Po dokončení čištění odeberte službu Cylance Cleanup Tool spuštěním následujícího příkazu pomocí nástroje pro správu systému, jako je Workspace ONE nebo System Center Configuration Manager společnosti Microsoft, nebo s oprávněními místního správce nebo místního počítače:
CyCleanupSvc.exe -uninstall

Vzdálený počítač (PsExec)

  1. Extrahujte soubory CyCleanupSvc.exe, CyCleanupSvc.exe.config a CylanceCleanupTool.bat do stejného adresáře v cílovém počítači.
  2. Na necílovém počítači otevřete příkazový řádek a spusťte následující příkaz:
psexec COMPUTER -accepteula -nobanner -u USERNAME -p PASSWORD -s "C:\Path\To\CylanceCleanupTool.bat"
Poznámka:
  • Nahraďte COMPUTER názvem cílového počítače.
  • Nahraďte USERNAME uživatelským jménem pro přihlášení ke vzdálenému počítači.
  • Nahraďte PASSWORD (volitelným) heslem pro výše uvedené uživatelské jméno. Pokud není zadáno žádné heslo, budete vyzváni k zadání hesla.
  1. Po dokončení čištění se ve složce, kde se nachází CyCleanupSvc.exe, vytvoří adresář Logs, který obsahuje soubor protokolu se seznamem úloh provedených nástrojem. Tento soubor protokolu lze v případě potřeby shromáždit.

Chcete-li kontaktovat podporu, přečtěte si článek Telefonní čísla mezinárodní podpory Dell Data Security.
Přejděte na portál TechDirect a vygenerujte online žádost o technickou podporu.
Další informace a zdroje získáte na fóru komunity Dell Security.

Dotčené produkty

Dell Threat Defense, Dell Endpoint Security Suite Enterprise
Vlastnosti článku
Číslo článku: 000131776
Typ článku: Solution
Poslední úprava: 19 dub 2026
Verze:  9
Najděte odpovědi na své otázky od ostatních uživatelů společnosti Dell
Služby podpory
Zkontrolujte, zda se na vaše zařízení vztahují služby podpory.