Prostředí VCF u sady VxRail: Během funkce PreCloneCheckCommonCallback došlo k chybě PBM.

Shrnutí: Při vytváření nového virtuálního počítače nebo klonování existujícího virtuálního počítače dojde k následující chybě: Došlo k obecné chybě systému: Během funkce PreCloneCheckCommonCallback došlo k chybě PBM: Příčina poruchy: pbm.fault.PBMFault; Nebyl nalezen žádný VASA Provider pro obor názvů schématu (VSAN). PBM označuje službu Profile-Driven Storage. ...

Tento článek se vztahuje na Tento článek se nevztahuje na Tento článek není vázán na žádný konkrétní produkt. V tomto článku nejsou uvedeny všechny verze produktu.

Příznaky

Při vytváření nového virtuálního počítače nebo klonování existujícího virtuálního počítače dojde k následující chybě:

A general system error occurred: PBM error occurred during PreCloneCheckCommonCallback: Fault cause: pbm.fault.PBMFault ; No VASA Provider for schema namespace (VSAN) found.
  • V poskytovatelích úložiště vCenter chybí poskytovatel sítě VSAN.
  • Služba vSAN Health se nespouští.
  • Služba SPS se nespouští.

Obrázek stavů služeb  

Příčina

Jde o známý problém. Za určitých okolností se konfigurační soubor /etc/vmware-vsan-health/logger.conf po aktualizaci neaktualizuje na nový formát používaný službou vSAN Health Service v nástroji vCenter. To vede k situacím, kdy rotace protokolu neprobíhá podle očekávání. 

Když se služba vSan Health spouští, pokusí se přečíst soubor větší než 10 GB, který překračuje časový limit pro spuštění služby.

Řešení

V sestaveních 7.0 U1 a novějších, kde je k dispozici starší konfigurační soubor, se aktualizuje na nový formát, i když je k dispozici starší konfigurační soubor. Chcete-li zkontrolovat, zda se jedná o váš problém, vyhledejte /etc/vmware-vsan-health/llogger.conf a ověřte velikost.

Alternativní řešení: 
Další informace naleznete v https://knowledge.broadcom.com/external/article?legacyId=82034Tento hypertextový odkaz vás zavede na webové stránky mimo společnost Dell Technologies..

  1. Odstraňte všechny obrovské soubory protokolu v níže uvedené složce:
/var/log/vmware/vsan-health
  1. Odstraňte níže uvedený soubor:
/etc/vmware-vsan-health/logger.conf
  1. Restartujte stav sítě vSAN pomocí příkazu:
vmon-cli -r vsan-health

Dotčené produkty

VxRail, VxRail E560 VCF, VxRail E560F VCF, VxRail E560N VCF, VxRail G560 VCF, VxRail G560F VCF, VxRail P570 VCF, VxRail P570F VCF, VxRail P580N VCF, VxRail S570 VCF, VxRail V570 VCF, VxRail V570F VCF
Vlastnosti článku
Číslo článku: 000208391
Typ článku: Solution
Poslední úprava: 08 zář 2025
Verze:  9
Najděte odpovědi na své otázky od ostatních uživatelů společnosti Dell
Služby podpory
Zkontrolujte, zda se na vaše zařízení vztahují služby podpory.