NVP – vProxy: Disk virtuálního počítače se nedaří zálohovat s chybou "VDDK Error: 13: Nemáte přístupová práva k tomuto souboru.... přípojný bod již existuje"

Shrnutí: Zálohujete virtuální počítač (VM) pomocí zařízení NetWorker VMware Protection (NVP) vProxy, ale jeden nebo více disků virtuálního počítače se nedaří zálohovat. Chyba "VDDK Error: 13: Nemáte přístupová práva k tomuto souboru." Jedná se o obecnou chybu, která se může objevit u několika příznaků. V tomto scénáři vbackupd-vddk.log vProxy indikuje, že přípojný bod již existuje. K tomu dochází, když soubor .vmdk virtuálního počítače zůstal připojený k serveru vProxy. ...

Tento článek se vztahuje na Tento článek se nevztahuje na Tento článek není vázán na žádný konkrétní produkt. V tomto článku nejsou uvedeny všechny verze produktu.

Příznaky

Integrace řešení NetWorker VMware Protection je konfigurována pomocí zařízení vProxy.  Zálohování virtuálního počítače (VM) se nepodaří zálohovat konkrétní disk (.vmdk).  Selhání konzole NetWorker Management Console (NMC) hlásí "Unable to backup virtual disk "Hard Disk #" bez dalších informací. 

Protokoly relace zálohování na serveru NetWorker nebo vProxy zobrazují pro dotčený soubor .vmdk následující informace:

Linux: /nsr/logs/policy/policy_name
Windows (výchozí): C:\Program Files\EMC NetWorker\nsr\logs\policy\policy_name
vProxy: /opt/emc/vproxy/runtime/logs/recycle/vbackupd/DATE/
YYYY/MM/DD HH:MM:SS ERROR:  [194] Failed to open source VMDK "[DATASTORE] VM_NAME/VM_NAME_1.vmdk": VDDK Error: 13: You do not have access rights to this file.
YYYY/MM/DD HH:MM:SS ERROR:  [194] "Hard disk 2": BackupVmdk: "Hard disk 2": Unable to open Virtual Disk "[DATASTORE] VM_NAME/VM_NAME_1.vmdk" in "hotadd" mode.
YYYY/MM/DD HH:MM:SS ERROR:  [194] "Hard disk 2": BackupVmdk: "Hard disk 2": Unable to open Virtual Disk "[DATASTORE] VM_NAME/VM_NAME_1.vmdk" in "hotadd" mode.
YYYY/MM/DD HH:MM:SS ERROR:  [194] "Hard disk 2": BackupVmdk: Failed backup.
 
V systému vProxy se v souboru /opt/emc/vproxy/runtime/logs/vbackupd-vddk.log zobrazí:
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: VixDiskLib_OpenEx: Cannot open disk [DATASTORE] VM_NAME/VM_NAME_1.vmdk. Error 13 (You do not have access rights to this file) (Mounting VM vm-### using transport hotadd failed : Mount point "/tmp/vmware-root/50268f14....177-vm-###/hotadd" already exists..) at 5026.
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: VixDiskLib_Open: Cannot open disk [DATASTORE] VM_NAME/VM_NAME_1.vmdk. Error 13 (You do not have access rights to this file) at 5064.
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: VixDiskLib_Disconnect: Disconnect.

Příčina

Soubor .vmdk virtuálního počítače zůstal po předchozí záloze připojen k zařízení vProxy, což vedlo k chybě "Mount point xxxxx already exists".

Řešení

K dispozici jsou dvě možnosti.

1. možnost:

Pomocí nástroje ProxyHC vyčistěte disky, které zůstaly na pozadí.

NVP-vProxy: Jak používat nástroj pro kontrolu stavu ProxyHC na zařízení

vProxyVýše uvedený článek znalostní databáze popisuje, jak získat a používat nástroj ProxyHC. Syntaxe potřebná pro tento konkrétní problém je:
./ProxyHC tasks disk cleanup

2. možnost:

Ruční vymazání nakonfigurovaných disků vProxy. Další soubory .vmdk musí být odpojeny od zařízení vProxy. Pokud server vProxy neprovádí žádné zálohování ani obnovení, zařízení vProxy by mělo mít k virtuálnímu počítači zařízení vProxy připojeny pouze dva soubory .vmdk.
 
1. Zastavte zálohování virtuálních počítačů procházející serverem vProxy a hlásí chybu "Mount point xxxxxx already exists".
2. Přihlaste se do webového klienta vCenter vSphere.
3. Pravým tlačítkem klikněte na zařízení vProxy a vyberte "Edit Settings..."
4. Zkontrolujte všechny disky, které patří jiným virtuálním počítačům:
Nastavení disku virtuálního počítače vProxy v systému vSphere
5. Pokud jsou k zařízení vProxy připojené nějaké další disky .vmdk, poznamenejte si název virtuálního počítače a odpojte disky. Soubory .vmdk obsahují název zobrazovaného názvu virtuálního počítače vSphere (nebo jiný název virtuálního počítače než název serveru vProxy).
VAROVÁNÍ: Nepoužívejte možnost "delete from datastore". Disk musí být odpojen od vProxy, nikoli odstraněn z úložiště. Neodstraňujte žádný disk, který patří k systému vProxy.
6. V systému vSphere vyhledejte virtuální počítač, jehož disky byly odpojeny od serveru vProxy.
7. Na kartě Souhrn virtuálního počítače klikněte v části Vlastní atributy na Upravit.
Vlastní atributy virtuálního počítače
8. Vyberte všechny atributy obsahující výraz "Dell EMC vProxy" a odstraňte je. Znovu se vytvoří při další akci vProxy. Odstraněním atributů zajistíte, že se vyčistí všechny zastaralé informace o relaci.
9. Restartujte zařízení vProxy.

Další informace

Dotčené produkty

NetWorker

Produkty

NetWorker
Vlastnosti článku
Číslo článku: 000031379
Typ článku: Solution
Poslední úprava: 24 Oct 2025
Verze:  6
Najděte odpovědi na své otázky od ostatních uživatelů společnosti Dell
Služby podpory
Zkontrolujte, zda se na vaše zařízení vztahují služby podpory.