VxRail: Nástroj vCenter hlásí nesprávnou kapacitu VSAN

Shrnutí: Nesprávná kapacita VSAN hlásí nástroj vCenter

Tento článek se vztahuje na Tento článek se nevztahuje na Tento článek není vázán na žádný konkrétní produkt. V tomto článku nejsou uvedeny všechny verze produktu.

Příznaky

Při kontrole kapacity VSAN z webového klienta vSphere je zobrazená kapacita VSAN nižší než očekávaná kapacita VSAN. RVC zobrazuje správnou kapacitu sítě VSAN.

V tomto případě měl každý uzel disky s kapacitou 3–1 TB, což celkem činilo ~13 TB celkové kapacity VSAN. Webový klient vSphere ukazoval hodnotu ~9 TB, jak je uvedeno níže:
Kapacita prostředí vSphere Web Client

Z RVC:

/localhost/MARVIN-Datacenter/datastores> ls
1 MARVIN-Virtual-SAN-Datastore-0385aed5-ddae-42f7-aab2-8fe5f992c9b9: 14258.75GB

 

Příčina

Jeden z hostitelů v clusteru se domníval, že je stále v režimu údržby. V nástroji vCenter se nezobrazoval v režimu údržby, ale výstup níže ukazoval, že je v režimu údržby:

Z hostitele esx spusťte následující příkaz.

cmmds-tool find -f python

A zkontrolujte decomState:

{
   "uuid": "57908981-beff-abdf-f76d-001e67dc4fc0",
   "owner": "57908981-beff-abdf-f76d-001e67dc4fc0",
   "health": "Healthy",
   "revision": "6",
   "type": "NODE_DECOM_STATE",
   "flag": "2",
   "minHostVersion": "0",
   "md5sum": "7c88fc7eea9891e32bc7b35532085ee5",
   "valueLen": "80",
---> looks like we're decommissioned due to Maintenance Mode:
   "content": "{\"decomState\": 6, \"decomJobType\": 1, \"decomJobUuid\": \"00000000-0000-0000-0000-000000000000\", \"progress\": 0, \"affObjList\": [ ], \"errorCode\": 0, \"updateNum\": 0, \"majorVersion\": 2}",
   "errorStr": "(null)"
},

Možné příčiny tohoto problému:

  1. Zničení skupiny disků bez uvedení uzlu do režimu údržby může uzel uvést do tohoto stavu. Tento problém nezpůsobuje, ale občas k němu může dojít.
  2. Může to způsobit neúspěšná údržba s úplnou migrací dat. Obvykle se jedná o nepřístupné a osamocené objekty, které mohou způsobit selhání hostitele při přechodu do režimu údržby (MM).
  3. Tento problém může způsobit odpojení a opětovné připojení uzlu od clusteru VSAN.

 

Řešení

Přepněte hostitele do režimu údržby (Zajistit usnadnění přístupu) a poté, co je hostitel v režimu údržby, ukončete režim údržby.
Poté by se kapacita VSAN měla ve webovém klientovi vSphere zobrazovat správně.

 

Dotčené produkty

VxRail Appliance Family

Produkty

VxRail Appliance Family
Vlastnosti článku
Číslo článku: 000052308
Typ článku: Solution
Poslední úprava: 17 Apr 2026
Verze:  6
Najděte odpovědi na své otázky od ostatních uživatelů společnosti Dell
Služby podpory
Zkontrolujte, zda se na vaše zařízení vztahují služby podpory.