Zálohování NMDA DB2 19.4.0.0 náhodně selhává každou noc s chybou 3
Shrnutí: NMDA 19.4.0.0 DB2 několik záloh DB2 selhalo včera v noci s chybou 3. Problém byl vyřešen po vytvoření nového zařízení a rozptýlení záloh do dvou uzlů úložiště a nastavení parametrů opakování a časového limitu v databázi DB2. ...
Tento článek se vztahuje na
Tento článek se nevztahuje na
Tento článek není vázán na žádný konkrétní produkt.
V tomto článku nejsou uvedeny všechny verze produktu.
Příznaky
NetWorker Client 19.4.0.0: AIX 7.2
NMDA 19.4.0.0, DB2 Server v11.1.4.4
Zálohy DB2 selhávají náhodně každou noc
Zálohování NMDA DB2 selže s chybou 3
Zálohování DB2 selže s chybou "lgto_auth pro 'nsrmmd' selhalo: busy"
Nebyly pozorovány
žádné problémy se sítí nebo firewallem V daemon.raw v uzlu úložiště je 1000 níže uvedených zpráv:
"Vyhledávání 5004-NFS selhalo (NFS: Žádný takový soubor nebo adresář)"
"invalid save stream"
""Nelze stat active file"
"unable to collect deduplikation statistics"
""byl přerušen a odstraněn ze svazku"
Error v nmda-messages.log libnsrdb2.log s debug=9:153929 9.
2. 2021 22:34:50 4 7 987 1 18153790 0 (klient) (pid18153790) NSR závažný Relaci zálohování nelze spustit: zaneprázdněn. <--- se jedná o čas EST, byl vykreslen v mém laboratoři
93412 9. 2. 2021 22:34:50 3 5 0 1 18153790 0 (klient) (pid18153790) Chyba NSR Nelze provést akci 2. Stav byl změněn na 3.
153929 1612842069 4 7 987 1 19136950 0 (klient) (PID19136950) NSR závažný 39 Relaci zálohování nelze spustit: %s. 1 49 8 0 4 zaneprázdněno <--- čase
GMT 93412 1612842069 3 5 0 1 19136950 0 (klient) (pid19136950) Chyba NSR 62 Could not perform the action %d. Stav byl změněn na %d. 2 1 1 2 1 1 3
(PID = 18809144) (02/09/21 21:40:00.338942) nsrdb2sv_log_program_args: /usr/bin/nsrdasv -LL -T db2 -s (NW server) -g (skupina) -a *policy action jobid=2297950 -a *policy name=(policy) -a *policy workflow name=(workflow) -a *policy action name=(action) -y Tue Feb 23 23:59:59 GMT-0600 2021 -w Tue Feb 23 23:59:59 GMT-0600 2021 -m (klient) -a *policy action jobid restart=Yes -b (pool) -t 1612810625 -o ....
(PID = 18809144) (02/09/21 21:40:00.624767) Probíhá zálohování databáze (DB).
(PID = 18809144) (02.09.21 21:40:00.624939) set_db2_version: Ukončení set_db2_version(): Return code: 10050000
(PID = 18809144) (02.09.21 21:49:08.731480) DbBackup: Ukončení s chybou:
Nelze zálohovat databázi DB2MDME kvůli selhání požadavku na zálohu, SQLCODE : -2025, SQL2025N Došlo k chybě I/O. Kód chyby: "3". Médium, na kterém k této chybě došlo: "DODAVATEL".
.
(PID = 18809144) (02.09.21 21:49:08.731631) libdb2sv_main: ERROR: Metoda DbBackup() se nezdařila.
(PID = 18809144) (02/09/21 21:49:08.731685) Nelze zálohovat databázi DB2MDME kvůli selhání požadavku na zálohu, SQLCODE : -2025, SQL2025N Došlo k chybě I/O. Kód chyby: "3". Médium, na kterém k této chybě došlo: "DODAVATEL".
Kritická chyba je NSRMMD Chyba zaneprázdnění níže:
02/09/21 21:32:46 (PID 18153790): 02.09.21 21:32:46.797073 lgto_auth pro 'nsrd' uspěl
02/09/21 21:32:46 (PID 18153790): 02.09.21 21:32:46.855631 lgto_parms for 'nsrmmd' úspěšně
02/09/21 21:32:46 (PID 18153790): 02/09/21 21:32:46.855705 dostal 'store index items' hodnotu 'Yes'02
/09/21 21:32:46 (PID 18153790): 02.09.21 21:32:46.855803 Ukládání do fondu 'IDC-DB2'.
02.09.21 21:32:46 (PID 18153790): 02/09/21 21:32:46.855822 Server povolen pro okamžitý režim
02/09/21 21:32:46 (PID 18153790): 02.09.21 21:32:46.882267 lgto_auth pro 'nsrmmd' se nezdařilo: zaneprázdněn
02/09/21 21:32:46 (PID 18153790): 02.09.21 21:32:46.882349 Nelze získat přihlašovací údaje uživatele pro přímé uložení Ověřování nsrmmd: zaneprázdněn.
02.09.21 21:32:46 (PID 18153790): 02.09.21 21:32:46.882439 Chyba TYPE je 0, SEVERITY je 0, NUMBER je -13, errnum je -13, errstr je 'busy'.
NMDA 19.4.0.0, DB2 Server v11.1.4.4
Zálohy DB2 selhávají náhodně každou noc
Zálohování NMDA DB2 selže s chybou 3
Zálohování DB2 selže s chybou "lgto_auth pro 'nsrmmd' selhalo: busy"
Nebyly pozorovány
žádné problémy se sítí nebo firewallem V daemon.raw v uzlu úložiště je 1000 níže uvedených zpráv:
"Vyhledávání 5004-NFS selhalo (NFS: Žádný takový soubor nebo adresář)"
"invalid save stream"
""Nelze stat active file"
"unable to collect deduplikation statistics"
""byl přerušen a odstraněn ze svazku"
Error v nmda-messages.log libnsrdb2.log s debug=9:153929 9.
2. 2021 22:34:50 4 7 987 1 18153790 0 (klient) (pid18153790) NSR závažný Relaci zálohování nelze spustit: zaneprázdněn. <--- se jedná o čas EST, byl vykreslen v mém laboratoři
93412 9. 2. 2021 22:34:50 3 5 0 1 18153790 0 (klient) (pid18153790) Chyba NSR Nelze provést akci 2. Stav byl změněn na 3.
153929 1612842069 4 7 987 1 19136950 0 (klient) (PID19136950) NSR závažný 39 Relaci zálohování nelze spustit: %s. 1 49 8 0 4 zaneprázdněno <--- čase
GMT 93412 1612842069 3 5 0 1 19136950 0 (klient) (pid19136950) Chyba NSR 62 Could not perform the action %d. Stav byl změněn na %d. 2 1 1 2 1 1 3
(PID = 18809144) (02/09/21 21:40:00.338942) nsrdb2sv_log_program_args: /usr/bin/nsrdasv -LL -T db2 -s (NW server) -g (skupina) -a *policy action jobid=2297950 -a *policy name=(policy) -a *policy workflow name=(workflow) -a *policy action name=(action) -y Tue Feb 23 23:59:59 GMT-0600 2021 -w Tue Feb 23 23:59:59 GMT-0600 2021 -m (klient) -a *policy action jobid restart=Yes -b (pool) -t 1612810625 -o ....
(PID = 18809144) (02/09/21 21:40:00.624767) Probíhá zálohování databáze (DB).
(PID = 18809144) (02.09.21 21:40:00.624939) set_db2_version: Ukončení set_db2_version(): Return code: 10050000
(PID = 18809144) (02.09.21 21:49:08.731480) DbBackup: Ukončení s chybou:
Nelze zálohovat databázi DB2MDME kvůli selhání požadavku na zálohu, SQLCODE : -2025, SQL2025N Došlo k chybě I/O. Kód chyby: "3". Médium, na kterém k této chybě došlo: "DODAVATEL".
.
(PID = 18809144) (02.09.21 21:49:08.731631) libdb2sv_main: ERROR: Metoda DbBackup() se nezdařila.
(PID = 18809144) (02/09/21 21:49:08.731685) Nelze zálohovat databázi DB2MDME kvůli selhání požadavku na zálohu, SQLCODE : -2025, SQL2025N Došlo k chybě I/O. Kód chyby: "3". Médium, na kterém k této chybě došlo: "DODAVATEL".
Kritická chyba je NSRMMD Chyba zaneprázdnění níže:
02/09/21 21:32:46 (PID 18153790): 02.09.21 21:32:46.797073 lgto_auth pro 'nsrd' uspěl
02/09/21 21:32:46 (PID 18153790): 02.09.21 21:32:46.855631 lgto_parms for 'nsrmmd' úspěšně
02/09/21 21:32:46 (PID 18153790): 02/09/21 21:32:46.855705 dostal 'store index items' hodnotu 'Yes'02
/09/21 21:32:46 (PID 18153790): 02.09.21 21:32:46.855803 Ukládání do fondu 'IDC-DB2'.
02.09.21 21:32:46 (PID 18153790): 02/09/21 21:32:46.855822 Server povolen pro okamžitý režim
02/09/21 21:32:46 (PID 18153790): 02.09.21 21:32:46.882267 lgto_auth pro 'nsrmmd' se nezdařilo: zaneprázdněn
02/09/21 21:32:46 (PID 18153790): 02.09.21 21:32:46.882349 Nelze získat přihlašovací údaje uživatele pro přímé uložení Ověřování nsrmmd: zaneprázdněn.
02.09.21 21:32:46 (PID 18153790): 02.09.21 21:32:46.882439 Chyba TYPE je 0, SEVERITY je 0, NUMBER je -13, errnum je -13, errstr je 'busy'.
Příčina
Problémy s konfigurací nebo dostupností zdrojů.
Řešení
Problém byl vyřešen po provedení níže uvedených změn. Neexistuje jediná hlavní příčina, ale nejvíce pomohlo vytvoření nového zařízení a nastavení níže uvedených parametrů:
1. Přidáno 1 nové zařízení do SN03
2. Distribuujte zálohy rovnoměrně do SN01 a SN03 (cílová relace atd.)
3. Změněné časy
zahájení zálohování 4. Do informací o aplikaci NMDA DB2 byly přidány tyto parametry:
NSR_MAX_START_RETRIES=50
NSR_FXBUSY_RETRIES=10
NSR_MMDB_RETRY_TIME=10
5. Zvýšen časový limit nečinnosti na 300, opakování = 2, zpoždění opakování = 10
1. Přidáno 1 nové zařízení do SN03
2. Distribuujte zálohy rovnoměrně do SN01 a SN03 (cílová relace atd.)
3. Změněné časy
zahájení zálohování 4. Do informací o aplikaci NMDA DB2 byly přidány tyto parametry:
NSR_MAX_START_RETRIES=50
NSR_FXBUSY_RETRIES=10
NSR_MMDB_RETRY_TIME=10
5. Zvýšen časový limit nečinnosti na 300, opakování = 2, zpoždění opakování = 10
Dotčené produkty
NetWorker Module for Databases and ApplicationsVlastnosti článku
Číslo článku: 000183668
Typ článku: Solution
Poslední úprava: 17 Jan 2026
Verze: 6
Najděte odpovědi na své otázky od ostatních uživatelů společnosti Dell
Služby podpory
Zkontrolujte, zda se na vaše zařízení vztahují služby podpory.