Connectrix řady MDS: Proces funkce CallHome přestane reagovat v show CallHome, show running-config nebo copy run start

Shrnutí: Proces CallHome způsobuje nedostupnost v show CallHome, show running-config nebo copy run start.

Tento článek se vztahuje na Tento článek se nevztahuje na Tento článek není vázán na žádný konkrétní produkt. V tomto článku nejsou uvedeny všechny verze produktu.

Příznaky

Dopad:
Nelze spustit:

copy running-config startup-config

Kvůli zámku CallHome Cisco Fabric Services (CFS) na topologii Fabric nelze provést žádné konfigurační operace.

Životní prostředí:
Všechny platformy MDS (Multilayer Director Switch). Tento problém byl zjištěn mimo jiné u přepínačů MDS 9710, 9396T a 9396S.

Známá dotčená vydání:

  • 8.4(2c)
  • 8.4(2b)
  • 8.4(1a)
  • 8.4(1)
  • Všechny přepínače Connectrix MDS

Vydat:
Následující příkaz přestane na neurčito reagovat:

show callhome

Následující příkaz se nespustí během 15 sekund (spuštění v prostředí uživatele trvalo v průměru 3 minuty):

show running-config

Následující příkaz v části show tech details zobrazí následující zprávu:

show run

The following SAPs did not respond within the expected timeframe
Pending SAPS:66
Printing Ascii configuration for remaining SAPs

Následující příkaz se zastaví kvůli selhání vypršení časového limitu:

copy run start

Example below: 
switch# copy run start
  [########################################]  98%Configuration update aborted: timed out
 
switch# show callhome
  Process did not respond within the expected timeframe, please try again.
  error-id 0x401e0045

Example show logging logfile:
%SYSMGR-3-CFGWRITE_SRVFAILED: Service "fscm" failed to store its configuration (error-id 0x40C0000E).
%SYSMGR-3-CFGWRITE_SRVTIMEOUT: Service "callhome server" failed to store its configuration in the timeout period

%SYSMGR-3-CFGWRITE_FAILED: Configuration copy failed (error-id 0x401E0045).
%LIBSYSMGR-3-CFGACTION_RSPFAILED: Unable to respond to System Manager's configuration action request for service "callhome server" (PID 5153): Broken pipe (32).

(SAP 66 which is of callhome process)

POZNÁMKY:
  • Příkaz show cfs lock nezobrazí žádný zámek cfc.
  • V protokolu syslog nebo nvram nejsou žádné zprávy.
  • Žádné problémy s komunikací mezi primárním slučovacím a jinými přepínači.
  • Nic v protokolech cfs se netýká funkce CallHome.
  • Žádné základní soubory.
  • Vymazání úplných systémů souborů nemá žádný efekt.
  • Zakázání nebo povolení funkce CallHome nemá žádný účinek.
  • Problém se vyskytuje na více přepínačích v topologii Fabric, nejen na primárním slučovacím systému.
  • Podmínka: 
Callhome is enabled as a CFS application
`show cfs application`
----------------------------------------------
 Application    Enabled   Scope
----------------------------------------------
 ntp            No        Physical-fc-ip
 fscm           Yes       Physical-fc
 role           No        Physical-fc-ip
 rscn           No        Logical
 radius         No        Physical-fc-ip
 fctimer        No        Physical-fc
 syslogd        No        Physical-fc-ip
 callhome       Yes       Physical-fc-ip
 fcdomain       No        Logical
 fc-redirect    Yes       Physical-fc
 device-alias   Yes       Physical-fc

Příčina

Problém Cisco CSCwb74960Tento hypertextový odkaz vás zavede na webové stránky mimo společnost Dell Technologies. (přístup k zobrazení problému společnosti Cisco může vyžadovat přihlášení na webové stránky společnosti Cisco).

Řešení

Alternativní řešení:
Zástupné řešení (bez rušení) je ukončit proces funkce CallHome pomocí Dplug. Otevřete servisní požadavek u týmu Dell Connectivity a uveďte toto číslo článku o pomoc s tímto problémem a Dplug.

Usnesení:
Technický tým společnosti Dell zkoumá řešení, které by tento problém vyřešilo upgradem na budoucí verzi kódu.

Dotčené produkty

Connectrix MDS-Series

Produkty

Connectrix MDS-9710, Connectrix MDS-9718-V3
Vlastnosti článku
Číslo článku: 000201233
Typ článku: Solution
Poslední úprava: 14 May 2026
Verze:  6
Najděte odpovědi na své otázky od ostatních uživatelů společnosti Dell
Služby podpory
Zkontrolujte, zda se na vaše zařízení vztahují služby podpory.